<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    
    <link rel="pingback" href="http://www.countercurrents.org/xmlrpc.php" />

    <title>The Farewell Sermon Of Prophet Muhammad &#8211; Countercurrents</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Feed" href="http://www.countercurrents.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Comments Feed" href="http://www.countercurrents.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; The Farewell Sermon Of Prophet Muhammad Comments Feed" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.countercurrents.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=fe20cadc087286a088a4a88c070ed9a6"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='popup-maker-site-css'  href='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/css/site.min.css?ver=1.6.6' type='text/css' media='all' />
<link rel='stylesheet' id='wpz-shortcodes-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/shortcodes.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-font-awesome-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/font-awesome.min.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='alpha-style-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/style.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/css/media-queries.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A400%2C700%7CSintony%3A400%2C700&#038;ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='socicon-css'  href='http://www.countercurrents.org/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/socicon.css?ver=20170209' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://www.countercurrents.org/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome.min.css?ver=20170209' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.countercurrents.org/wp-includes/css/dashicons.min.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wzslider-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/wzslider.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-theme-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/styles/default.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/custom.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='http://www.countercurrents.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.countercurrents.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.countercurrents.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Führer Trump Tweets Neo-Nazi Anti-Muslim Propaganda' href='http://www.countercurrents.org/2017/12/01/fuhrer-trump-tweets-neo-nazi-anti-muslim-propaganda/' />
<link rel='next' title='Waiting For The American Dream' href='http://www.countercurrents.org/2017/12/01/waiting-for-the-american-dream/' />

<link rel="canonical" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/" />
<link rel='shortlink' href='http://www.countercurrents.org/?p=19832' />
<link rel="alternate" type="application/json+oembed" href="http://www.countercurrents.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.countercurrents.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://www.countercurrents.org/wp-content/plugins/category-specific-rss-feed-menu/wp_cat_rss_style.css" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.countercurrents.org/?wordfence_lh=1&hid=B867DD492953EEB64B7EE25E6FE5794C');
</script>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><!-- WPZOOM Theme / Framework -->
<meta name="generator" content="Alpha 2.1.0" />
<meta name="generator" content="WPZOOM Framework 1.6.1" />
<style type="text/css">@import url("http://fonts.googleapis.com/css?family=Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Merriweather|Merriweather|Open+Sans:r,i,b,bi");
#menutop{background:#040507;}
#menu{background:#FFCC2A;}
#news-ticker{background:#FFFDCA;}
.container{background:#FFFFFF;}
body{color: #000000;font-family: 'Open Sans';font-style: normal;}#logo h1 a{font-family: 'Open Sans';}#slider #slidemain .slide_content h2{font-family: 'Open Sans';font-weight: bold;}.left-col h2, .right-col h4{font-family: 'Open Sans';font-weight: bold;}.archiveposts h2{font-family: 'Merriweather';font-weight: bold;}h1.title{font-family: 'Merriweather';font-weight: bold;}.widget h3.title{font-family: 'Open Sans';font-weight: bold;}</style>
<script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Farewell Sermon Of Prophet Muhammad" />
<meta property="og:url" content="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/" />
<meta property="og:description" content="(Birth anniversary of Prophet Muhammad-2nd December 2017) As you read these lines, 1.6 billion Muslims across the world, from Morocco to Jakarta, will be paying homage to the Prophet Muhammad on hi…" />
<meta property="article:published_time" content="2017-12-01T08:15:06+00:00" />
<meta property="article:modified_time" content="2017-12-01T08:15:06+00:00" />
<meta property="og:site_name" content="Countercurrents" />
<meta property="og:image" content="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?fit=1200%2C630" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?fit=1200%2C630&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
	<style id="pum-styles" type="text/css" media="all">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</style></head>
<body class="single single-post postid-19832 single-format-standard custom-background">

    <header id="header">

        <div id="menutop">
            <div class="inner-wrap">

                
                    <a class="btn_menu" id="toggle-top" href="#"></a>

                    <div id="topmenu-wrap">

                        <ul id="topmenu" class="dropdown"><li id="menu-item-2096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2096"><a href="http://www.countercurrents.org/subscription/">Subscription</a></li>
<li id="menu-item-2095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2095"><a href="http://www.countercurrents.org/news-letter/">News Letter</a></li>
<li id="menu-item-2003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2003"><a href="http://www.countercurrents.org/fair-use-notice/">Fair Use</a></li>
<li id="menu-item-2004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2004"><a href="http://www.countercurrents.org/disclaimer/">Disclaimer</a></li>
<li id="menu-item-2005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2005"><a href="http://www.countercurrents.org/countercurrents-submission-policy/">Submission</a></li>
<li id="menu-item-2006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006"><a href="http://www.countercurrents.org/contact/">Contact</a></li>
<li id="menu-item-2007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2007"><a href="http://www.countercurrents.org/about/">About</a></li>
</ul>
                    </div>

                
                                    <div id="navsocial">

                        <div id="zoom-social-icons-widget-2" class="widget zoom-social-icons-widget"><h3 class="title">Social Icons</h3>
		
		<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link"
					   href="https://facebook.com/countercurrents"
						target="_blank"											>
																								<span class="zoom-social_icons-list-span socicon socicon-facebook"
							data-hover-rule="background-color" data-hover-color="#3b5998"							  style="background-color : #3b5998; font-size: 18px; padding:8px"
						></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link"
					   href="https://twitter.com/Countercurrents"
						target="_blank"											>
																								<span class="zoom-social_icons-list-span socicon socicon-twitter"
							data-hover-rule="background-color" data-hover-color="#55acee"							  style="background-color : #55acee; font-size: 18px; padding:8px"
						></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link"
					   href="https://plus.google.com/112168561804759773712"
						target="_blank"											>
																								<span class="zoom-social_icons-list-span socicon socicon-google"
							data-hover-rule="background-color" data-hover-color="#d93e2d"							  style="background-color : #d93e2d; font-size: 18px; padding:8px"
						></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link"
					   href="http://feeds.feedburner.com/countercurrents/eoKx"
						target="_blank"											>
																								<span class="zoom-social_icons-list-span socicon socicon-rss"
														  style="background-color : #ffcc2a; font-size: 18px; padding:8px"
						></span>

											</a>
				</li>

			
								<li class="zoom-social_icons-list__item">
					<a class="zoom-social_icons-list__link"
					   href="https://www.youtube.com/user/CCMEDIACHANNEL"
						target="_blank"											>
																								<span class="zoom-social_icons-list-span socicon socicon-youtube"
														  style="background-color : #bd332f; font-size: 18px; padding:8px"
						></span>

											</a>
				</li>

			
		</ul>

		<div class="clear"></div></div>
                    </div>
                
                <div class="clear"></div>

            </div><!-- /.inner-wrap -->

        </div><!-- /#menutop -->

        <div class="inner-wrap header-wrap">

            <div id="logo">
                
                <a href="http://www.countercurrents.org" title="Educate | Organize | Agitate">
                                            <img src="http://www.countercurrents.org//wp-content/uploads/2016/06/logo-1.png" alt="Countercurrents" />
                                    </a>

                            </div><!-- / #logo -->


            
            <div class="clear"></div>


            <div id="menu">

                <a class="btn_menu" id="toggle-main" href="#"></a>

                <div id="menu-wrap">

                    <ul id="mainmenu" class="dropdown"><li id="menu-item-1887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1887"><a href="http://www.countercurrents.org">Home</a></li>
<li id="menu-item-1848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1848"><a href="http://www.countercurrents.org/category/world/">World</a>
<ul class="sub-menu">
	<li id="menu-item-1822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1822"><a href="http://www.countercurrents.org/category/palestine/">Palestine</a></li>
	<li id="menu-item-2024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2024"><a href="http://www.countercurrents.org/category/imperialism/">Imperialism</a></li>
	<li id="menu-item-2054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2054"><a href="http://www.countercurrents.org/category/south-asia/">South Asia</a></li>
</ul>
</li>
<li id="menu-item-1821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1821"><a href="http://www.countercurrents.org/category/india/">India</a>
<ul class="sub-menu">
	<li id="menu-item-2026" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2026"><a href="http://www.countercurrents.org/category/communal-harmony/">Communal Harmony</a></li>
	<li id="menu-item-2025" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2025"><a href="http://www.countercurrents.org/category/annihilate-caste/">Annihilate Caste</a></li>
	<li id="menu-item-1845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1845"><a href="http://www.countercurrents.org/category/kashmir/">Kashmir</a></li>
</ul>
</li>
<li id="menu-item-2027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2027"><a href="http://www.countercurrents.org/category/climate-change/">Climate Change</a>
<ul class="sub-menu">
	<li id="menu-item-2029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2029"><a href="http://www.countercurrents.org/category/environmental-protection/">Environmental Protection</a></li>
	<li id="menu-item-2030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2030"><a href="http://www.countercurrents.org/category/resource-crisis/">Resource Crisis</a></li>
	<li id="menu-item-2028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2028"><a href="http://www.countercurrents.org/category/counter-solutions/">Counter Solutions</a></li>
	<li id="menu-item-2057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2057"><a href="http://www.countercurrents.org/category/alternative-energy/">Alternative Energy</a></li>
</ul>
</li>
<li id="menu-item-1969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1969"><a href="http://www.countercurrents.org/category/globalisation/">Globalisation</a></li>
<li id="menu-item-2031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2031"><a href="http://www.countercurrents.org/category/patriarchy/">Patriarchy</a></li>
<li id="menu-item-2045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2045"><a href="http://www.countercurrents.org/category/human-rights/">Human Rights</a></li>
<li id="menu-item-2046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2046"><a href="http://www.countercurrents.org/category/life-philosophy/">Life/Philosophy</a>
<ul class="sub-menu">
	<li id="menu-item-2055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2055"><a href="http://www.countercurrents.org/category/arts-literature/">Arts/Literature</a></li>
	<li id="menu-item-2056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2056"><a href="http://www.countercurrents.org/category/book-review/">Book Review</a></li>
</ul>
</li>
</ul>
                </div>

                
                <div class="clear"></div>

            </div><!-- /#menu -->

        </div><!-- /.inner-wrap -->

    </header>

    	<div class="inner-wrap">
		<div id="news-ticker">

			
			<div class="first">
				<dl id="ticker">
 
				
		 			<p>There are no breaking news at the moment</p>

 				  
				</dl>
			</div>
		 			</div>	
	</div>
    <div class="container">
        <div class="content-wrap">
<div class="single-area">

	 
		<div class="post-meta">
			 
		 	<h1 class="title">
				<a href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/" title="Permalink to The Farewell Sermon Of Prophet Muhammad" rel="bookmark">The Farewell Sermon Of Prophet Muhammad</a>
			</h1>

			in <a href="http://www.countercurrents.org/category/communal-harmony/" rel="category tag">Communal Harmony</a> <span class="separator">&mdash;</span>  			by <a href="http://www.countercurrents.org/author/moin-qazi/" title="Posts by Moin Qazi" rel="author">Moin Qazi</a> <span class="separator">&mdash;</span>			December 1, 2017 					
		</div><!-- /.post-meta -->

	  		<div id="post-19832" class="clearfix post-wrap post-19832 post type-post status-publish format-standard has-post-thumbnail hentry category-communal-harmony">
 	 	  
			<div class="entry">
				<p style="text-align: center;"><img class="aligncenter size-full wp-image-19833" src="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?resize=690%2C362" alt="the farewell sermon of Hazrat Muhammad (S.A.W)" srcset="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?w=1200 1200w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?resize=300%2C158 300w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?resize=768%2C403 768w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?resize=1024%2C538 1024w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W.jpg?resize=105%2C55 105w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1" /></p>
<p><strong>(Birth anniversary of Prophet Muhammad-2<sup>nd</sup> December 2017)</strong></p>
<p>As you read these lines, 1.6 billion Muslims across the world, from Morocco to Jakarta, will be paying homage to the Prophet Muhammad on his birthday.</p>
<p>This day, 1,428 years ago, Prophet Muhammad delivered the historic Last Sermon (<em>khutabat al-wida</em>) on the parched terrain of Mount of Mercy (<em>Jabal ar-Rahmah</em>) in the Uranah valley of Mount Arafat, 20 kilometres east of Mecca. It was precisely  on the ninth day of Dhu al-Hijjah(12th and last month of the Islamic year -6 March 632)) in the tenth year of <em>hijrah</em>(migration from Mecca to Medina )   that  the Prophet addressed 1,44,000 pilgrims  The sermon , though seemingly addressed to a Muslim gathering, had a universal message. It    consists of summarized exhortations based on some core teachings of the Qur’an and <em>sunnah</em> (Prophetic practices).It captures the ethos of Islam and provides a great lens to view the religion through. Some of his advices have become the fundamental touchstones of the Islamic faith.</p>
<p>Muslims use the occasion a propitious time to rededicate themselves to the universal human values such as sacredness of life and property, equality, justice, peace, forgiveness, non-violence, women’s rights, the pillars of Islam and more. Upon these lofty principles, the religion of Islam was built. The Prophet died after unifying Arabia and his lifelong declared love of learning protected and contributed to classical knowledge and continued the tradition of Persian scholarship during the dark ages of Christendom.</p>
<p>For centuries, the Prophet inspired the Muslim world to thrive economically, culturally, scientifically and artistically. More than 1,400 years on, the   divine providence of his philosophy, among myriad other socio-economic and political factors continue to anchor Muslim civilization.</p>
<p>We still have so much to learn from this 1,400-plus-year-old cry and we are so much in need of this message of Prophet Muhammad to soothe and heal our broken times where we continue to struggle with almost identical issues in our global human community.</p>
<p>The content of the message was powerful and intense, and the Prophet began by stating that he did not know whether he would meet the pilgrims again ‘in this place after this year’. After praising God and declaring the basic creed, ‘There is no deity but Allah and Muhammad is His Messenger’, he went on to speak on various themes. He then reminded them of the sacred character of the place and month, as well as of that of their lives, their honour, and their belongings.</p>
<p>He explained that the period of ignorance had come to an end, and so had its practices, its rivalries, and its conflicts based on power and profit. Henceforth, all Muslims were united by faith, fraternity and love, which were to transform them into witnesses of Islam’s message. They must under no circumstances accept being ‘either oppressors or oppressed’. They were to learn of the equality of all people in front of God and the desired humility because, he said “You all descend from Adam and Adam was created from dirt. The most noble in the sight of God is the most pious. No Arab is superior to a non-Arab, except by their intimate consciousness of God [piety].”</p>
<p>He reiterated the need for tolerance to people of all denominations: &#8216;¿an Arab has no superiority over a non-Arab, nor a non-Arab has any superiority over an Arab; also a white has no superiority over a black, nor a black has any superiority over white except by piety and good action.</p>
<p>The Prophet reminded all Muslims to treat their wives gently and added: “Be intimately conscious of God as regards women, and strive to be good to them.” He then added, as if to show the way and its conditions to all the faithful present and all those who were to follow his teachings through the ages: “I have left among you what will, if you keep to it firmly, preserve you from error: clear guidance, the Book of God and His Prophet’s tradition.” After each teaching that he reminded them of, the Prophet added: ‘Have I conveyed the Message? O God, be my witness!” At the end of the sermon, the pilgrims answered: “We bear witness that you have faithfully conveyed the message, that you have fulfilled your mission, and that you have given your community good advice.”</p>
<p>Concluding the sermon, the Prophet said, “You will be questioned about me (on the Day of Judgment). What answer will you give?” They replied, “We will bear witness that you conveyed to us what you were entrusted with….” The Prophet then pointed towards the people and said, thrice: “O Lord bear witness!” O God, be my witness! …. And let whoever is present convey this message to whoever is absent.”</p>
<p>A few hours later,   near the summit of Arafat, the revelation came down: “…This day have I perfected your religion for you, completed My Grace upon you, and have chosen Islam for you as your religion…” (Quran 5:3).</p>
<p>The last cycle of prophethood was drawing to its close, and the Messenger was to return to the place of his election, his home beyond this life, in proximity to the One.</p>
<p><strong>Here is his sermon.</strong></p>
<p>“O People, listen well to my words, for I do not know whether, after this year, I shall ever be among you again. Therefore, listen to what I am saying to you very carefully and take these words to those who could not be present here today.</p>
<p>“O People, just as you regard this month, this day, this city as Sacred, so regard the life and property of every Muslim as a sacred trust. Return the goods entrusted to you to their rightful owners. Treat others justly so that no one would be unjust to you. Remember that you will indeed meet your LORD, and that HE will indeed reckon your deeds. God has forbidden you to take usury (<em>riba</em>), therefore all <em>riba </em>obligations shall henceforth be waived. Your capital, however, is yours to keep. You will neither inflict nor suffer inequity. God has judged that there shall be no <em>riba </em>and that all the <em>riba </em>due to <code>Abbas ibn</code>Abd al Muttalib shall henceforth be waived.</p>
<p>“Every right arising out of homicide and blood-killing in pre-Islamic days is henceforth waived and the first such right that I waive is that arising from the murder of Rabi<code>ah ibn al Harith ibn</code>Abd al Muttalib.</p>
<p>“O people, the Unbelievers indulge in tampering with the calendar in order to make permissible that which God forbade, and to forbid that which God has made permissible. With God the months are 12 in number. Four of them are sacred, three of these are successive and one occurs singly between the months of Jumada and Sha`ban. Beware of the devil, for the safety of your religion. He has lost all hope that he will ever be able to lead you astray in big things, so beware of following him in small things.</p>
<p>“O People, it is true that you have certain rights over your women, but they also have rights over you. Remember that you have taken them as your wives only under God’s trust and with His permission. If they abide by your right then to them belongs the right to be fed and clothed in kindness. Treat your women well and be kind to them, for they are your partners and committed helpers. It is your right and they do not make friends with anyone of whom you do not approve, as well as never to be unchaste&#8230;</p>
<p>“O People, listen to me in earnest, worship God (The One Creator of the Universe), perform your five daily prayers (<em>salah</em>), fast during the month of Ramadan, and give your financial obligation (<em>zakah</em>) of your wealth. Perform <em>hajj </em>if you can afford to.</p>
<p>“All mankind is from Adam and Eve. An Arab has no superiority over a non-Arab nor a non-Arab has any superiority over an Arab; also a white has no superiority over a black nor a black has any superiority over white except by piety and good action. Learn that every Muslim is a brother to every Muslim and that the Muslims constitute one brotherhood. Nothing shall be legitimate to a Muslim which belongs to a fellow Muslim unless it was given freely and willingly. Do not, therefore, do injustice to yourselves.</p>
<p>“Remember, one day you will appear before God (The Creator) and you will answer for your deeds. So beware, do not stray from the path of righteousness after I am gone.</p>
<p>“O People, no prophet or messenger will come after me and no new faith will be born. Reason well, therefore, O People, and understand words, which I convey to you. I am leaving you with the Book of God (the Quran) and my <em>sunnah </em>(the sayings and   practices as evidenced in the   behavioural mode of the Prophet). If you follow them you will never go astray.</p>
<p>“All those who listen to me shall pass on my words to others and those to others again; and may the last ones understand my words better than those who listen to me directly. Be my witness O God, that I have conveyed your message to your people.”</p>
<p>(Reference: See Al-Bukhari, Hadith 1623, 1626, 6361) Sahih of Imam Muslim also refers to this sermon in Hadith number 98. Imam al-Tirmidhi has mentioned this sermon in Hadith nos. 1628, 2046, 2085. Imam Ahmed bin Hanbal has given us the longest and perhaps the most complete version of this sermon in his Masnud, Hadith no. 19774.)</p>
<p><strong>Moin Qazi</strong> is the author of the bestselling book, Village Diary of a Heretic Banker .He has worked in the development finance sector for almost four decades .He can be reached at <strong>moinqazi123@gmail.com</strong></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-19832" class="share-facebook sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-19832" class="share-twitter sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=The%20Farewell%20Sermon%20Of%20Prophet%20Muhammad http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-19832" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-19832" class="share-linkedin sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-19832" class="share-pinterest sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-19832" class="share-skype sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>				<div class="clear"></div>
				
								<div class="clear"></div>
			
			</div><!-- / .entry -->
			<div class="clear"></div>
            <div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> 	<div class="clear"></div> 	
			
 	 	</div><!-- #post-19832 -->
		
		
		<div class="clear"></div>

	 	 
					<div class="post-wrap"><div id="comments">




		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/01/the-farewell-sermon-of-prophet-muhammad/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=113156937&#038;postid=19832&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.9&#038;sig=ddf18eb05dc407aff78fbda50cade16b416aca09#parent=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments --></div>
				
	  
</div><!-- /.single-area -->
	
	
<div id="sidebar">

		
	
	<div id="text-6" class="widget widget_text"><h3 class="title">Site Search</h3><div class="widget-content">			<div class="textwidget"><div id="search"> 
	<form method="get" id="searchform" action="http://www.google.com/search">
		<input type="text" name="q" id="q" size="30"  value="" placeholder="Site search...">
 <input type="hidden" name="domains" value="http://www.countercurrents.org">
<input type=hidden name=sitesearch value="http://www.countercurrents.org" >		
<input type="submit" name="btnG" id="searchsubmit" class="submit"  VALUE="Search">
		
	</form>
</div></div>
		<div class="clear"></div></div></div><div id="widget_sp_image-3" class="widget widget_sp_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="http://www.countercurrents.org/subscription" id="subscription" target="_self" class="widget_sp_image-image-link" title="Annual Subscription"><img width="300" height="98" alt="Annual Subscription" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?w=327 327w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?resize=300%2C98 300w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?resize=168%2C55 168w" sizes="(max-width: 300px) 100vw, 300px" src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?fit=300%2C98" /></a><div class="clear"></div></div></div><div id="text-8" class="widget widget_text"><h3 class="title">Join Our News Letter</h3><div class="widget-content">			<div class="textwidget"><form method="post" action="http://scripts.dreamhost.com/add_list.cgi">
        
          <input type="hidden" name="list" value="editor" />
          <input type="hidden" name="domain" value="http://www.countercurrents.org" />
          <input type="hidden" name="url" value="SubscribedURL" />
          <input type="hidden" name="unsuburl" value="UnsubscribedURL" />
          <input type="hidden" name="alreadyonurl" value="AlreadyOnURL" />
          <input type="hidden" name="notonurl" value="NotOnURL" />
          <input type="hidden" name="invalidurl" value="InvalidURL" />
          <input type="hidden" name="emailconfirmurl" value="EmailConfirmURL" />
          <input type="hidden" name="emailit" value="1" />
          
       <p> Name:     <input name="name" />   </p>
        
        <p>E-mail: <input name="email" /></p>
        <p>        
          <input type="submit" name="submit" value="Subscribe" />
          <input type="submit" name="unsub" value="Unsubscribe" />
        </p>
      </form></div>
		<div class="clear"></div></div></div>
			<div id="wpzoom-tabber-2" class="widget tabbertabs"><div class="tabber"><div id="wpzoom-feature-posts-2" class="tabbertab feature-posts"><h2 class="widgettitle">Latest</h2>
<ul class="feature-posts-list"><li><a href="http://www.countercurrents.org/2017/12/01/the-fccs-order-is-out-heres-what-you-need-to-know-it-will-end-net-neutrality-and-break-the-internet/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/internet-savenetneutrality-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/the-fccs-order-is-out-heres-what-you-need-to-know-it-will-end-net-neutrality-and-break-the-internet/">The FCC’s Order Is Out, Here’s What You Need to Know: It Will End Net Neutrality And Break the Internet</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/matt-wood/" title="Posts by Matt Wood" rel="author">Matt Wood</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/waiting-for-the-american-dream/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/4030400633_fc53cbfb5d_b_autumn-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/waiting-for-the-american-dream/">Waiting For The American Dream</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/edward-curtin/" title="Posts by Edward Curtin" rel="author">Edward Curtin</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/the-farewell-sermon-of-Hazrat-Muhammad-S.A.W-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/the-farewell-sermon-of-prophet-muhammad/">The Farewell Sermon Of Prophet Muhammad</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/moin-qazi/" title="Posts by Moin Qazi" rel="author">Moin Qazi</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/fuhrer-trump-tweets-neo-nazi-anti-muslim-propaganda/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/N0-trump2-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/fuhrer-trump-tweets-neo-nazi-anti-muslim-propaganda/">Führer Trump Tweets Neo-Nazi Anti-Muslim Propaganda</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/sunsara-taylor/" title="Posts by Sunsara Taylor" rel="author">Sunsara Taylor</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/genocidal-u-s-thanksgiving-celebrated-even-in-cambodia/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/thanksgiving-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/genocidal-u-s-thanksgiving-celebrated-even-in-cambodia/">Genocidal U.S Thanksgiving Celebrated Even In Cambodia</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/andre-vltchek/" title="Posts by Andre Vltchek" rel="author">Andre Vltchek</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/mauritania-and-much-more-undimmed-for-the-damned/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/modern_slavery_humans_opt-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/mauritania-and-much-more-undimmed-for-the-damned/">Mauritania And Much More Undimmed For The Damned</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/richard-oxman/" title="Posts by Richard Oxman" rel="author">Richard Oxman</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/google-ministry-of-truth-intensifies-suppressing-fake-news-such-as-this/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/google_fake_news-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/google-ministry-of-truth-intensifies-suppressing-fake-news-such-as-this/"> Google ‘Ministry of Truth’ Intensifies Suppressing ‘Fake News’ (Such As This)</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/eric-zuesse/" title="Posts by Eric Zuesse" rel="author">Eric Zuesse</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/mammoth-divorce-bills-the-eu-and-the-surrender-of-the-brexiters/"><img src="http://www.countercurrents.org/wp-content/uploads/2016/06/brexit-sign-eu-referendum-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/mammoth-divorce-bills-the-eu-and-the-surrender-of-the-brexiters/">Mammoth Divorce Bills: The EU And The Surrender Of The Brexiters</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/binoy-kampmark/" title="Posts by Dr Binoy Kampmark" rel="author">Dr Binoy Kampmark</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/100-freedom-activists-call-for-investigation-of-ahmed-molas-assassination/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/Mola-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/100-freedom-activists-call-for-investigation-of-ahmed-molas-assassination/">100 Freedom Activists Call For Investigation Of Ahmed Mola’s Assassination</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/rahim-hamid/" title="Posts by Rahim Hamid" rel="author">Rahim Hamid</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/the-lesson-kim-jong-un-learned-from-the-u-s/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/08/Kim-Jong-Un-attack-Trump-US-world-war-north-korea-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/the-lesson-kim-jong-un-learned-from-the-u-s/">The Lesson Kim Jong Un Learned From The U.S</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-arshad-m-khan/" title="Posts by Dr Arshad M Khan" rel="author">Dr Arshad M Khan</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/bad-cop-and-bad-judge-you-decide/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/pipe-75x50.png" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/bad-cop-and-bad-judge-you-decide/">Bad Cop And Bad Judge? You Decide</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/sally-dugman/" title="Posts by Sally Dugman" rel="author">Sally Dugman</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/12/01/give-some-place-in-your-heart-for-kidneys-please/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/12/kidneys-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/12/01/give-some-place-in-your-heart-for-kidneys-please/">Give Some Place In Your Heart For Kidneys! Please!</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/moin-qazi/" title="Posts by Moin Qazi" rel="author">Moin Qazi</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/trump-retweets-fascist-anti-muslim-videos-from-britain/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/05/idiot_trump-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/trump-retweets-fascist-anti-muslim-videos-from-britain/">Trump Retweets Fascist Anti-Muslim Videos From Britain</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/fred-mazelis/" title="Posts by Fred Mazelis" rel="author">Fred Mazelis</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/backlash-against-russian-fake-news-is-shutting-down-debate-for-real/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/google_fake_news-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/backlash-against-russian-fake-news-is-shutting-down-debate-for-real/">Backlash Against Russian ‘Fake News’ Is Shutting Down Debate For Real</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-robin-andersen/" title="Posts by Dr Robin Andersen" rel="author">Dr Robin Andersen</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/decades-of-us-diplomacy-has-failed-why-the-us-wants-to-shut-down-plo-office/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/PLO-Office-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/decades-of-us-diplomacy-has-failed-why-the-us-wants-to-shut-down-plo-office/">Decades Of US Diplomacy Has Failed: Why The US Wants To Shut Down PLO Office</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-ramzy-baroud/" title="Posts by Dr Ramzy Baroud" rel="author">Dr Ramzy Baroud</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/palestinian-genocide-imposing-apartheid-israel-complicit-in-rohingya-genocide-other-genocides-us-uk-australian-state-terrorism/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/10/rohingya-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/palestinian-genocide-imposing-apartheid-israel-complicit-in-rohingya-genocide-other-genocides-us-uk-australian-state-terrorism/">Palestinian Genocide–imposing Apartheid Israel Complicit In Rohingya Genocide, Other Genocides &#038; US, UK &#038; Australian State Terrorism</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-gideon-polya/" title="Posts by Dr Gideon Polya" rel="author">Dr Gideon Polya</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/ahwazi-activists-cling-to-hope-as-iranian-regime-persecution-worsens/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/ahwazi-prisoners-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/ahwazi-activists-cling-to-hope-as-iranian-regime-persecution-worsens/">Ahwazi Activists Cling To Hope As Iranian Regime Persecution Worsens</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/rahim-hamid/" title="Posts by Rahim Hamid" rel="author">Rahim Hamid</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/killing-the-biosphere-to-fast-track-human-extinction/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/polar-bear-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/killing-the-biosphere-to-fast-track-human-extinction/">Killing The Biosphere To Fast-Track Human Extinction</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/robert-j-burrowes/" title="Posts by Robert J Burrowes" rel="author">Robert J Burrowes</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/theatre-death-and-the-icty-the-suicide-of-slobodan-praljak/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/11/Slobodan-Praljak-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/theatre-death-and-the-icty-the-suicide-of-slobodan-praljak/">Theatre, Death And The ICTY: The Suicide of Slobodan Praljak</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/binoy-kampmark/" title="Posts by Dr Binoy Kampmark" rel="author">Dr Binoy Kampmark</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/11/30/cbms-for-the-youth/"><img src="http://www.countercurrents.org/wp-content/uploads/2016/07/kashmir-children-759-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/11/30/cbms-for-the-youth/">CBM’s For The Youth!</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/mohammad-ashraf/" title="Posts by Mohammad Ashraf" rel="author">Mohammad Ashraf</a></span>
                <div class="clear"></div></li></ul><div class="clear"></div></div><div id="wpzoom-popular-news-2" class="tabbertab popular-news"><h2 class="widgettitle">Popular</h2>
<ul class='popular'>
<li><a href='http://www.countercurrents.org/2016/07/26/open-letter-to-major-gaurav-arya-veteran/' rel='bookmark'>Open Letter To Major Gaurav Arya (Veteran)</a> <span class='comments' href='http://www.countercurrents.org/2016/07/26/open-letter-to-major-gaurav-arya-veteran/'>45 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/09/29/adivasis-dance-today-the-first-fir-filed-against-durga-puja/' rel='bookmark'>Adivasis Dance Today: The First Ever FIR Filed Against Durga Puja</a> <span class='comments' href='http://www.countercurrents.org/2017/09/29/adivasis-dance-today-the-first-fir-filed-against-durga-puja/'>39 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/01/28/trump-orders-military-to-prepare-for-war/' rel='bookmark'>Trump Orders Military To Prepare For War</a> <span class='comments' href='http://www.countercurrents.org/2017/01/28/trump-orders-military-to-prepare-for-war/'>34 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/07/22/poison-in-the-heart-the-nuclear-wasting-of-south-australia/' rel='bookmark'>Poison In The Heart: The Nuclear Wasting Of South Australia</a> <span class='comments' href='http://www.countercurrents.org/2016/07/22/poison-in-the-heart-the-nuclear-wasting-of-south-australia/'>23 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/11/02/rakesh-sharma-demolishes-the-script-of-m-p-police-on-bhopal-encounter/' rel='bookmark'>Rakesh Sharma Demolishes The Script of M.P Police on Bhopal Encounter</a> <span class='comments' href='http://www.countercurrents.org/2016/11/02/rakesh-sharma-demolishes-the-script-of-m-p-police-on-bhopal-encounter/'>19 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/08/04/open-letter-by-burhan-wani-to-major-arya/' rel='bookmark'>Open Letter By Burhan Wani To Major Arya  </a> <span class='comments' href='http://www.countercurrents.org/2016/08/04/open-letter-by-burhan-wani-to-major-arya/'>16 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/04/19/an-open-letter-from-a-kashmiri-student-to-the-people-of-india/' rel='bookmark'>An Open Letter From A Kashmiri Student To The People Of India</a> <span class='comments' href='http://www.countercurrents.org/2017/04/19/an-open-letter-from-a-kashmiri-student-to-the-people-of-india/'>16 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/07/22/koch-brothers-now-supporting-hillary-clinton/' rel='bookmark'> Koch Brothers Now Supporting Hillary Clinton</a> <span class='comments' href='http://www.countercurrents.org/2016/07/22/koch-brothers-now-supporting-hillary-clinton/'>13 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/11/19/demonetisation-and-bhakts/' rel='bookmark'>Demonetisation And Bhakts</a> <span class='comments' href='http://www.countercurrents.org/2016/11/19/demonetisation-and-bhakts/'>13 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/09/25/i-am-losing-faith-kancha-ilaiah/' rel='bookmark'>I Am Losing Faith: Kancha Ilaiah</a> <span class='comments' href='http://www.countercurrents.org/2017/09/25/i-am-losing-faith-kancha-ilaiah/'>13 comments</span></li>
</ul>
</div><div id="wpzoom-recent-comments-2" class="tabbertab recent-comments"><h2 class="widgettitle">Comments</h2>
<ul class="recent-comments-list">
		<li>
			<a href="http://www.countercurrents.org/2017/12/01/give-some-place-in-your-heart-for-kidneys-please/#comment-7959"><img alt='' src='http://0.gravatar.com/avatar/f3b7c03a5da013e70a3b0538b3920ef5?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/f3b7c03a5da013e70a3b0538b3920ef5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/12/01/give-some-place-in-your-heart-for-kidneys-please/#comment-7959">Sally Dugman:</a> It is listed on my daughter's and my driver's licenses that &hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/24/no-new-mass-shootings-in-the-last-five-minutes/#comment-7958"><img alt='' src='http://1.gravatar.com/avatar/ae97007491a48361a9ea327c5fab27b5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/ae97007491a48361a9ea327c5fab27b5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/24/no-new-mass-shootings-in-the-last-five-minutes/#comment-7958">C. Ikehara:</a> - It has become appallingly obvious that our technology has &hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/30/trump-retweets-fascist-anti-muslim-videos-from-britain/#comment-7957"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/30/trump-retweets-fascist-anti-muslim-videos-from-britain/#comment-7957">rosemerry:</a> If that Jayded Frustrated thing is a Christian, we are not i&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/29/abominations-abroad-and-our-addictions-advice-for-parents-and-teachers/#comment-7956"><img alt='' src='http://0.gravatar.com/avatar/37635dd3517c01463c0515cab5011c93?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/37635dd3517c01463c0515cab5011c93?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/29/abominations-abroad-and-our-addictions-advice-for-parents-and-teachers/#comment-7956">Marianne van Heerden:</a> Surely it is time for Africans to change their attitudes. Ho&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/30/hadiyas-plight-in-a-nation-of-snake-oil-sellers/#comment-7954"><img alt='' src='http://2.gravatar.com/avatar/2ef7312c7b895d395aad958accc4d880?s=60&#038;r=g' srcset='http://2.gravatar.com/avatar/2ef7312c7b895d395aad958accc4d880?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/30/hadiyas-plight-in-a-nation-of-snake-oil-sellers/#comment-7954">FATHIMA:</a> A well balanced but honest way of narrating the truth.   Lov&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/29/borneo-island-devastated-people-oblivious/#comment-7951"><img alt='' src='http://2.gravatar.com/avatar/e292c26a85f32256c2d342ac928254b2?s=60&#038;r=g' srcset='http://2.gravatar.com/avatar/e292c26a85f32256c2d342ac928254b2?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/29/borneo-island-devastated-people-oblivious/#comment-7951">Monica:</a> Thank you Mr. Andre Vitchek for exposing the evils of the pa&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/29/environmentalists-are-earths-antibodies/#comment-7950"><img alt='' src='http://0.gravatar.com/avatar/f49adec1337c15d8364fe988f958de8a?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/f49adec1337c15d8364fe988f958de8a?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/29/environmentalists-are-earths-antibodies/#comment-7950">David Anderson:</a> Well said,    History has taught us that societal change gen&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/28/how-iran-came-to-be-called-the-top-state-sponsor-of-terrorism/#comment-7945"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/28/how-iran-came-to-be-called-the-top-state-sponsor-of-terrorism/#comment-7945">rosemerry:</a> Lots of info, but surely it is obvious that Sunni Arabs are &hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/28/the-rhetorical-trap-north-korea-as-state-sponsor-of-terrorism/#comment-7944"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/28/the-rhetorical-trap-north-korea-as-state-sponsor-of-terrorism/#comment-7944">rosemerry:</a> The hypocrisy of the USA, the world's largest sponsor of war&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/11/28/the-betraying-arab-league/#comment-7943"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/11/28/the-betraying-arab-league/#comment-7943">rosemerry:</a> Thanks to Dr Elias Akleh for this account. The situation kee&hellip;<div class="clear"></div>
		</li>

			</ul></div><div id="tag_cloud-3" class="tabbertab widget_tag_cloud"><h2 class="widgettitle">Tags</h2>
<div class="tagcloud"><a href='http://www.countercurrents.org/tag/aadhaar-card/' class='tag-link-1046 tag-link-position-1' title='29 topics' style='font-size: 9.9310344827586pt;'>Aadhaar Card</a>
<a href='http://www.countercurrents.org/tag/afghanistan/' class='tag-link-702 tag-link-position-2' title='28 topics' style='font-size: 9.6091954022988pt;'>Afghanistan</a>
<a href='http://www.countercurrents.org/tag/ahwazi-arab/' class='tag-link-232 tag-link-position-3' title='26 topics' style='font-size: 9.1264367816092pt;'>Ahwazi Arab</a>
<a href='http://www.countercurrents.org/tag/american-imperialism/' class='tag-link-156 tag-link-position-4' title='95 topics' style='font-size: 17.977011494253pt;'>American Imperialism</a>
<a href='http://www.countercurrents.org/tag/annihilate-caste/' class='tag-link-151 tag-link-position-5' title='33 topics' style='font-size: 10.735632183908pt;'>Annihilate Caste</a>
<a href='http://www.countercurrents.org/tag/bangladesh/' class='tag-link-163 tag-link-position-6' title='22 topics' style='font-size: 8pt;'>Bangladesh</a>
<a href='http://www.countercurrents.org/tag/beef-ban/' class='tag-link-426 tag-link-position-7' title='43 topics' style='font-size: 12.505747126437pt;'>Beef Ban</a>
<a href='http://www.countercurrents.org/tag/beef-ban-lynching/' class='tag-link-573 tag-link-position-8' title='28 topics' style='font-size: 9.6091954022988pt;'>Beef Ban Lynching</a>
<a href='http://www.countercurrents.org/tag/brexit/' class='tag-link-189 tag-link-position-9' title='41 topics' style='font-size: 12.183908045977pt;'>Brexit</a>
<a href='http://www.countercurrents.org/tag/burhan-wani/' class='tag-link-379 tag-link-position-10' title='23 topics' style='font-size: 8.3218390804598pt;'>Burhan Wani</a>
<a href='http://www.countercurrents.org/tag/cartoons/' class='tag-link-1390 tag-link-position-11' title='30 topics' style='font-size: 10.091954022989pt;'>Cartoons</a>
<a href='http://www.countercurrents.org/tag/climate-change/' class='tag-link-174 tag-link-position-12' title='111 topics' style='font-size: 19.103448275862pt;'>Climate Change</a>
<a href='http://www.countercurrents.org/tag/counter-solutions/' class='tag-link-185 tag-link-position-13' title='27 topics' style='font-size: 9.448275862069pt;'>Counter Solutions</a>
<a href='http://www.countercurrents.org/tag/dakota-access-pipeline/' class='tag-link-656 tag-link-position-14' title='80 topics' style='font-size: 16.850574712644pt;'>Dakota Access Pipeline</a>
<a href='http://www.countercurrents.org/tag/demonetisation/' class='tag-link-925 tag-link-position-15' title='121 topics' style='font-size: 19.747126436782pt;'>Demonetisation</a>
<a href='http://www.countercurrents.org/tag/donald-trump/' class='tag-link-353 tag-link-position-16' title='169 topics' style='font-size: 22pt;'>Donald Trump</a>
<a href='http://www.countercurrents.org/tag/education/' class='tag-link-331 tag-link-position-17' title='49 topics' style='font-size: 13.471264367816pt;'>Education</a>
<a href='http://www.countercurrents.org/tag/gauri-lankesh/' class='tag-link-1508 tag-link-position-18' title='32 topics' style='font-size: 10.574712643678pt;'>Gauri Lankesh</a>
<a href='http://www.countercurrents.org/tag/global-warming/' class='tag-link-193 tag-link-position-19' title='69 topics' style='font-size: 15.885057471264pt;'>Global Warming</a>
<a href='http://www.countercurrents.org/tag/gmo/' class='tag-link-209 tag-link-position-20' title='27 topics' style='font-size: 9.448275862069pt;'>GMO</a>
<a href='http://www.countercurrents.org/tag/health/' class='tag-link-301 tag-link-position-21' title='30 topics' style='font-size: 10.091954022989pt;'>Health</a>
<a href='http://www.countercurrents.org/tag/hillary-clinton/' class='tag-link-308 tag-link-position-22' title='56 topics' style='font-size: 14.436781609195pt;'>Hillary Clinton</a>
<a href='http://www.countercurrents.org/tag/human-rights/' class='tag-link-152 tag-link-position-23' title='50 topics' style='font-size: 13.632183908046pt;'>Human Rights</a>
<a href='http://www.countercurrents.org/tag/india-pakistan-peace-initiative/' class='tag-link-724 tag-link-position-24' title='23 topics' style='font-size: 8.3218390804598pt;'>India-Pakistan Peace Initiative</a>
<a href='http://www.countercurrents.org/tag/india-now/' class='tag-link-1392 tag-link-position-25' title='26 topics' style='font-size: 9.1264367816092pt;'>India Now</a>
<a href='http://www.countercurrents.org/tag/isis/' class='tag-link-299 tag-link-position-26' title='22 topics' style='font-size: 8pt;'>ISIS</a>
<a href='http://www.countercurrents.org/tag/israel/' class='tag-link-218 tag-link-position-27' title='59 topics' style='font-size: 14.758620689655pt;'>Israel</a>
<a href='http://www.countercurrents.org/tag/kashmir/' class='tag-link-164 tag-link-position-28' title='125 topics' style='font-size: 19.908045977011pt;'>Kashmir</a>
<a href='http://www.countercurrents.org/tag/k-p-sasi-cartoons/' class='tag-link-1391 tag-link-position-29' title='29 topics' style='font-size: 9.9310344827586pt;'>K P Sasi Cartoons</a>
<a href='http://www.countercurrents.org/tag/narmada-bachao-andolan/' class='tag-link-311 tag-link-position-30' title='40 topics' style='font-size: 12.022988505747pt;'>Narmada Bachao Andolan</a>
<a href='http://www.countercurrents.org/tag/north-korea/' class='tag-link-611 tag-link-position-31' title='32 topics' style='font-size: 10.574712643678pt;'>North Korea</a>
<a href='http://www.countercurrents.org/tag/nuclear-war/' class='tag-link-198 tag-link-position-32' title='26 topics' style='font-size: 9.1264367816092pt;'>Nuclear War</a>
<a href='http://www.countercurrents.org/tag/palestine/' class='tag-link-217 tag-link-position-33' title='74 topics' style='font-size: 16.367816091954pt;'>Palestine</a>
<a href='http://www.countercurrents.org/tag/peak-oil/' class='tag-link-169 tag-link-position-34' title='35 topics' style='font-size: 11.218390804598pt;'>Peak Oil</a>
<a href='http://www.countercurrents.org/tag/poetry/' class='tag-link-228 tag-link-position-35' title='86 topics' style='font-size: 17.333333333333pt;'>Poetry</a>
<a href='http://www.countercurrents.org/tag/resource-crisis/' class='tag-link-170 tag-link-position-36' title='24 topics' style='font-size: 8.6436781609195pt;'>Resource Crisis</a>
<a href='http://www.countercurrents.org/tag/rohingya-muslims/' class='tag-link-872 tag-link-position-37' title='38 topics' style='font-size: 11.701149425287pt;'>Rohingya Muslims</a>
<a href='http://www.countercurrents.org/tag/rss/' class='tag-link-186 tag-link-position-38' title='26 topics' style='font-size: 9.1264367816092pt;'>RSS</a>
<a href='http://www.countercurrents.org/tag/standing-rock-sioux-protest/' class='tag-link-655 tag-link-position-39' title='79 topics' style='font-size: 16.689655172414pt;'>Standing Rock Sioux Protest</a>
<a href='http://www.countercurrents.org/tag/syria/' class='tag-link-244 tag-link-position-40' title='100 topics' style='font-size: 18.298850574713pt;'>Syria</a>
<a href='http://www.countercurrents.org/tag/the-commons/' class='tag-link-344 tag-link-position-41' title='90 topics' style='font-size: 17.655172413793pt;'>The Commons</a>
<a href='http://www.countercurrents.org/tag/turkey/' class='tag-link-309 tag-link-position-42' title='25 topics' style='font-size: 8.8045977011494pt;'>Turkey</a>
<a href='http://www.countercurrents.org/tag/us-elections-2016/' class='tag-link-283 tag-link-position-43' title='89 topics' style='font-size: 17.494252873563pt;'>US Elections 2016</a>
<a href='http://www.countercurrents.org/tag/us-travel-ban/' class='tag-link-1152 tag-link-position-44' title='24 topics' style='font-size: 8.6436781609195pt;'>US Travel Ban</a>
<a href='http://www.countercurrents.org/tag/yemen/' class='tag-link-489 tag-link-position-45' title='32 topics' style='font-size: 10.574712643678pt;'>Yemen</a></div>
</div>
			<div class="clear"></div></div></div><div id="wpzoom-videos-4" class="widget widget_wpzoom_videos"><h3 class="title">Videos            <a href="http://www.countercurrents.org/type/video/" class="see-all">See All &raquo;</a>

            </h3><div class="widget-content">

        <div id="recent-videos" class="flexslider">

            
                    <ul class="slides">

                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/82jFyeV5AHM?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2017/01/16/chennai-poromboke-paadal-ft-tm-krishna/" rel="bookmark" title="Permanent Link to Chennai Poromboke Paadal ft. TM Krishna">Chennai Poromboke Paadal ft. TM Krishna</a></h4>

                            </li>
                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/suBzeCjqRb4?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2017/01/14/notebandi-takes-the-sauce-out-of-nashiks-tomatoes/" rel="bookmark" title="Permanent Link to Notebandi Takes The Sauce Out Of Nashik’s Tomatoes">Notebandi Takes The Sauce Out Of Nashik’s Tomatoes</a></h4>

                            </li>
                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/c1UiNHjS12Q?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2016/12/30/farmers-continue-to-suffer-pains-of-demonetisation/" rel="bookmark" title="Permanent Link to Farmers Continue To Suffer Pains Of Demonetisation">Farmers Continue To Suffer Pains Of Demonetisation</a></h4>

                            </li>
                        
                    </ul>


            

        </div>

<div class="clear"></div></div></div>		<div class="featured-category">
            <h3 class="green"><a href="http://www.countercurrents.org/category/editors-picks/">Editor&#8217;s Picks</a></h3>
            
			
				<div class="left-col">

					<a href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/" title="The Elippathayam (Rat Trap) Moment Of Indian Cinema"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/sexy-durga-nude.jpg?resize=300%2C200" alt="The Elippathayam (Rat Trap) Moment Of Indian Cinema" class="Thumbnail thumbnail featured-cat " width="300" height="200" /></a>					<div class="clear"></div>

					<div class="left-col-content">

						<h2><a href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/" title="The Elippathayam (Rat Trap) Moment Of Indian Cinema">The Elippathayam (Rat Trap) Moment Of Indian Cinema</a></h2>

						<div class="featured-meta">
							<!--<span></span>-->
                            by							<a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a>							<span class="separator">&mdash;</span>
							<span><a href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/#comments">1 comment</a></span>
						</div>

						<p>Elippathayam (The Rat Trap) is a 1981 Malayalam film written and directed by Adoor Gopalakrishnan. It tells the story of a man trapped within himself unable to understand the changes taking place around him. It seems Indian Cinema also is caught in rat trap. No, it would be a bit flattering for Indian Cinema to use the rat trap metaphor.<a class="more-link" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/">[Read More&#8230;]</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-19430" class="share-facebook sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-19430" class="share-twitter sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=The%20Elippathayam%20%28Rat%20Trap%29%20Moment%20Of%20Indian%20Cinema http%3A%2F%2Fwww.countercurrents.org%2F2017%2F11%2F17%2Fthe-elippathayam-rat-trap-moment-of-indian-cinema%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-19430" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-19430" class="share-linkedin sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-19430" class="share-pinterest sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-19430" class="share-skype sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.countercurrents.org/2017/11/17/the-elippathayam-rat-trap-moment-of-indian-cinema/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					</div>

				</div>

				<div class="right-col">
					<ul>

											
						<li>
							<a href="http://www.countercurrents.org/2017/11/14/the-climate-emergency-two-time-scales-john-averys-latest-book-free-to-download/" title="&#8220;The Climate Emergency: Two Time Scales&#8221; &#8211; John Avery&#8217;s Latest Book Free To Download"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery-cover.jpg?resize=100%2C75" alt="&#8220;The Climate Emergency: Two Time Scales&#8221; &#8211; John Avery&#8217;s Latest Book Free To Download" class="Thumbnail thumbnail featured-cat-small " width="100" height="75" /></a>
							<div class="right-col-content">

								<h4><a href="http://www.countercurrents.org/2017/11/14/the-climate-emergency-two-time-scales-john-averys-latest-book-free-to-download/" title="&#8220;The Climate Emergency: Two Time Scales&#8221; &#8211; John Avery&#8217;s Latest Book Free To Download">&#8220;The Climate Emergency: Two Time Scales&#8221; &#8211; John Avery&#8217;s Latest Book Free To Download</a></h4>

								<div class="featured-meta">
									<!--<span>November 14, 2017</span>-->
                                    by							<a href="http://www.countercurrents.org/author/john-scales-avery/" title="Posts by John Scales Avery" rel="author">John Scales Avery</a>									<span class="separator">&mdash;</span>
									<span><a href="http://www.countercurrents.org/2017/11/14/the-climate-emergency-two-time-scales-john-averys-latest-book-free-to-download/#comments">5 comments</a></span>
								</div>

							</div>

							<div style="clear:both;"></div>

						</li>

												
						<li>
							<a href="http://www.countercurrents.org/2017/09/29/adivasis-dance-today-the-first-fir-filed-against-durga-puja/" title="Adivasis Dance Today: The First Ever FIR Filed Against Durga Puja"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/09/mahishasur.jpg?resize=100%2C75" alt="Adivasis Dance Today: The First Ever FIR Filed Against Durga Puja" class="Thumbnail thumbnail featured-cat-small " width="100" height="75" /></a>
							<div class="right-col-content">

								<h4><a href="http://www.countercurrents.org/2017/09/29/adivasis-dance-today-the-first-fir-filed-against-durga-puja/" title="Adivasis Dance Today: The First Ever FIR Filed Against Durga Puja">Adivasis Dance Today: The First Ever FIR Filed Against Durga Puja</a></h4>

								<div class="featured-meta">
									<!--<span>September 29, 2017</span>-->
                                    by							<a href="http://www.countercurrents.org/author/dr-goldy-m-george/" title="Posts by Dr Goldy M. George" rel="author">Dr Goldy M. George</a>									<span class="separator">&mdash;</span>
									<span><a href="http://www.countercurrents.org/2017/09/29/adivasis-dance-today-the-first-fir-filed-against-durga-puja/#comments">39 comments</a></span>
								</div>

							</div>

							<div style="clear:both;"></div>

						</li>

																	</ul>
	              	            </div>
				<div class="clear"></div>
		</div><!-- / .category -->
 <!-- / .featCategory --><div id="archives-2" class="widget widget_archive"><h3 class="title">Archives</h3><div class="widget-content">		<ul>
			<li><a href='http://www.countercurrents.org/2017/12/'>December 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/11/'>November 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/10/'>October 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/09/'>September 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/08/'>August 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/07/'>July 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/06/'>June 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/05/'>May 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/04/'>April 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/03/'>March 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/02/'>February 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/01/'>January 2017</a></li>
	<li><a href='http://www.countercurrents.org/2016/12/'>December 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/11/'>November 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/10/'>October 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/09/'>September 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/08/'>August 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/07/'>July 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/06/'>June 2016</a></li>
		</ul>
		<div class="clear"></div></div></div><div id="widget_sp_image-4" class="widget widget_sp_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="http://www.countercurrents.org/archive.htm" target="_self" class="widget_sp_image-image-link" title="Older Archive"><img width="300" height="98" alt="Older Archive" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?w=327 327w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?resize=300%2C98 300w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?resize=168%2C55 168w" sizes="(max-width: 300px) 100vw, 300px" src="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?fit=300%2C98" /></a><div class="clear"></div></div></div><div id="text-3" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=258076111050631";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div class="fb-page" data-href="https://www.facebook.com/countercurrents/" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/countercurrents/"><a href="https://www.facebook.com/countercurrents/">Countercurrents</a></blockquote></div></div></div>
		<div class="clear"></div></div></div><div id="text-4" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget">
<a href="https://twitter.com/Countercurrents" class="twitter-follow-button" data-show-count="false" data-size="large" data-dnt="true">Follow @Countercurrents</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>


</div>
		<div class="clear"></div></div></div><div id="text-11" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget"><!-- Place this tag in your head or just before your close body tag. -->
<script src="https://apis.google.com/js/platform.js" async defer></script>

<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-href="https://plus.google.com/112168561804759773712" data-rel="publisher"></div></div>
		<div class="clear"></div></div></div><div id="widget_sp_image-8" class="widget widget_sp_image"><h3 class="title">DOWNLOAD FOR FREE &#8211; &#8220;The Climate Emergency: Two Time Scales&#8221; By John Avery </h3><div class="widget-content"><a href="http://www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery.pdf" target="_self" class="widget_sp_image-image-link" title="DOWNLOAD FOR FREE &#8211; &#8220;The Climate Emergency: Two Time Scales&#8221; By John Avery "><img width="300" height="340" alt="DOWNLOAD FOR FREE &#8211; &#8220;The Climate Emergency: Two Time Scales&#8221; By John Avery " class="attachment-full" style="max-width: 100%;" srcset="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery-cover.jpg?w=300 300w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery-cover.jpg?resize=265%2C300 265w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery-cover.jpg?resize=49%2C55 49w" sizes="(max-width: 300px) 100vw, 300px" src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/11/climate-emergency-avery-cover.jpg?fit=300%2C340" /></a><div class="clear"></div></div></div><div id="widget_sp_image-6" class="widget widget_sp_image"><h3 class="title">The Political Economy Of Beef Ban</h3><div class="widget-content"><a href="http://peoplesbookshop.com/product/political-economy-beef-ban/" target="_blank" class="widget_sp_image-image-link" title="The Political Economy Of Beef Ban"><img width="300" height="340" alt="The Political Economy Of Beef Ban" class="attachment-full" style="max-width: 100%;" srcset="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/beefbook-forcc.jpg?w=300 300w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/beefbook-forcc.jpg?resize=265%2C300 265w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/beefbook-forcc.jpg?resize=49%2C55 49w" sizes="(max-width: 300px) 100vw, 300px" src="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/beefbook-forcc.jpg?fit=300%2C340" /></a><div class="clear"></div></div></div><div id="widget_sp_image-5" class="widget widget_sp_image"><h3 class="title">Countercurrents Anthology-Vol 1</h3><div class="widget-content"><a href="http://peoplesbookshop.com/product/countercurrents-connecting-dots-anthology/" target="_blank" class="widget_sp_image-image-link" title="Countercurrents Anthology-Vol 1"><img width="300" height="300" alt="Countercurrents Anthology-Vol 1" class="attachment-full" style="max-width: 100%;" srcset="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?w=300 300w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=150%2C150 150w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=55%2C55 55w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=75%2C75 75w" sizes="(max-width: 300px) 100vw, 300px" src="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?fit=300%2C300" /></a><div class="clear"></div></div></div><div id="widget_sp_image-2" class="widget widget_sp_image"><h3 class="title">Countercurrents Youtube Channel</h3><div class="widget-content"><a href="http://www.youtube.com/ccmediachannel" target="_blank" class="widget_sp_image-image-link" title="Countercurrents Youtube Channel"><img width="327" height="107" alt="Countercurrents Youtube Channel" class="attachment-full aligncenter" style="max-width: 100%;" srcset="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?w=327 327w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?resize=300%2C98 300w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?resize=168%2C55 168w" sizes="(max-width: 327px) 100vw, 327px" src="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?fit=327%2C107" /></a><div class="clear"></div></div></div> 
		
  
		 
</div> <!-- /#sidebar --> 
				<div class="clear"></div>

				<div id="footer">

						<div class="column">
							<div id="text-2" class="widget widget_text"><h3 class="title">Annual Subscription</h3><div class="widget-content">			<div class="textwidget">If you like what you are reading please join our annual subscription programme. Countercurrents.org is a 100% reader supported website.  We believe independent journalism will function properly only if it is economically independent.  We do not accept advertising by our policy. We would rather die than accept advertisements from corporate giants. A small annual subscription sustains us. Get an annual subscription 
<a href="http://www.countercurrents.org/cc/subscription">HERE</a>
</div>
		<div class="clear"></div></div></div>						</div><!-- /1st column -->

						<div class="column">
							<div id="text-13" class="widget widget_text"><h3 class="title">Join Our News Letter</h3><div class="widget-content">			<div class="textwidget">Keep Uptodate With The World!!! Join Our News Letter Today !! We tell you what the mainstream media fails to tell you, or hides from you. These are the things that really matter. The things which may determine the fate of planet earth! The future of our children! In a word, the survival of the species! To receive our daily news digest please click <a href="http://www.countercurrents.org/cc/news-letter/">HERE</a></div>
		<div class="clear"></div></div></div>						</div><!-- /2nd column -->

						<div class="column">
							<div id="text-12" class="widget widget_text"><h3 class="title">Submission Guidelines</h3><div class="widget-content">			<div class="textwidget">Countercurrents.org welcomes articles from writers, activists, journalists and also from our readers who have no prior experience in writing, on topics that we deal with regularly or on topics that you think need a wider circulation. Kindly use the word "SUBMISSION" in the subject line You can submit your articles to editor@countercurrents.org. More Submission guidelines are <a href="http://www.countercurrents.org/cc/countercurrents-submission-policy/"> HERE</a> </div>
		<div class="clear"></div></div></div>						</div><!-- /3rd column -->

						<div class="column last">
							<div id="tag_cloud-4" class="widget widget_tag_cloud"><h3 class="title">Popular Tags</h3><div class="widget-content"><div class="tagcloud"><a href='http://www.countercurrents.org/tag/aadhaar-card/' class='tag-link-1046 tag-link-position-1' title='29 topics' style='font-size: 9.9310344827586pt;'>Aadhaar Card</a>
<a href='http://www.countercurrents.org/tag/afghanistan/' class='tag-link-702 tag-link-position-2' title='28 topics' style='font-size: 9.6091954022988pt;'>Afghanistan</a>
<a href='http://www.countercurrents.org/tag/ahwazi-arab/' class='tag-link-232 tag-link-position-3' title='26 topics' style='font-size: 9.1264367816092pt;'>Ahwazi Arab</a>
<a href='http://www.countercurrents.org/tag/american-imperialism/' class='tag-link-156 tag-link-position-4' title='95 topics' style='font-size: 17.977011494253pt;'>American Imperialism</a>
<a href='http://www.countercurrents.org/tag/annihilate-caste/' class='tag-link-151 tag-link-position-5' title='33 topics' style='font-size: 10.735632183908pt;'>Annihilate Caste</a>
<a href='http://www.countercurrents.org/tag/bangladesh/' class='tag-link-163 tag-link-position-6' title='22 topics' style='font-size: 8pt;'>Bangladesh</a>
<a href='http://www.countercurrents.org/tag/beef-ban/' class='tag-link-426 tag-link-position-7' title='43 topics' style='font-size: 12.505747126437pt;'>Beef Ban</a>
<a href='http://www.countercurrents.org/tag/beef-ban-lynching/' class='tag-link-573 tag-link-position-8' title='28 topics' style='font-size: 9.6091954022988pt;'>Beef Ban Lynching</a>
<a href='http://www.countercurrents.org/tag/brexit/' class='tag-link-189 tag-link-position-9' title='41 topics' style='font-size: 12.183908045977pt;'>Brexit</a>
<a href='http://www.countercurrents.org/tag/burhan-wani/' class='tag-link-379 tag-link-position-10' title='23 topics' style='font-size: 8.3218390804598pt;'>Burhan Wani</a>
<a href='http://www.countercurrents.org/tag/cartoons/' class='tag-link-1390 tag-link-position-11' title='30 topics' style='font-size: 10.091954022989pt;'>Cartoons</a>
<a href='http://www.countercurrents.org/tag/climate-change/' class='tag-link-174 tag-link-position-12' title='111 topics' style='font-size: 19.103448275862pt;'>Climate Change</a>
<a href='http://www.countercurrents.org/tag/counter-solutions/' class='tag-link-185 tag-link-position-13' title='27 topics' style='font-size: 9.448275862069pt;'>Counter Solutions</a>
<a href='http://www.countercurrents.org/tag/dakota-access-pipeline/' class='tag-link-656 tag-link-position-14' title='80 topics' style='font-size: 16.850574712644pt;'>Dakota Access Pipeline</a>
<a href='http://www.countercurrents.org/tag/demonetisation/' class='tag-link-925 tag-link-position-15' title='121 topics' style='font-size: 19.747126436782pt;'>Demonetisation</a>
<a href='http://www.countercurrents.org/tag/donald-trump/' class='tag-link-353 tag-link-position-16' title='169 topics' style='font-size: 22pt;'>Donald Trump</a>
<a href='http://www.countercurrents.org/tag/education/' class='tag-link-331 tag-link-position-17' title='49 topics' style='font-size: 13.471264367816pt;'>Education</a>
<a href='http://www.countercurrents.org/tag/gauri-lankesh/' class='tag-link-1508 tag-link-position-18' title='32 topics' style='font-size: 10.574712643678pt;'>Gauri Lankesh</a>
<a href='http://www.countercurrents.org/tag/global-warming/' class='tag-link-193 tag-link-position-19' title='69 topics' style='font-size: 15.885057471264pt;'>Global Warming</a>
<a href='http://www.countercurrents.org/tag/gmo/' class='tag-link-209 tag-link-position-20' title='27 topics' style='font-size: 9.448275862069pt;'>GMO</a>
<a href='http://www.countercurrents.org/tag/health/' class='tag-link-301 tag-link-position-21' title='30 topics' style='font-size: 10.091954022989pt;'>Health</a>
<a href='http://www.countercurrents.org/tag/hillary-clinton/' class='tag-link-308 tag-link-position-22' title='56 topics' style='font-size: 14.436781609195pt;'>Hillary Clinton</a>
<a href='http://www.countercurrents.org/tag/human-rights/' class='tag-link-152 tag-link-position-23' title='50 topics' style='font-size: 13.632183908046pt;'>Human Rights</a>
<a href='http://www.countercurrents.org/tag/india-pakistan-peace-initiative/' class='tag-link-724 tag-link-position-24' title='23 topics' style='font-size: 8.3218390804598pt;'>India-Pakistan Peace Initiative</a>
<a href='http://www.countercurrents.org/tag/india-now/' class='tag-link-1392 tag-link-position-25' title='26 topics' style='font-size: 9.1264367816092pt;'>India Now</a>
<a href='http://www.countercurrents.org/tag/isis/' class='tag-link-299 tag-link-position-26' title='22 topics' style='font-size: 8pt;'>ISIS</a>
<a href='http://www.countercurrents.org/tag/israel/' class='tag-link-218 tag-link-position-27' title='59 topics' style='font-size: 14.758620689655pt;'>Israel</a>
<a href='http://www.countercurrents.org/tag/kashmir/' class='tag-link-164 tag-link-position-28' title='125 topics' style='font-size: 19.908045977011pt;'>Kashmir</a>
<a href='http://www.countercurrents.org/tag/k-p-sasi-cartoons/' class='tag-link-1391 tag-link-position-29' title='29 topics' style='font-size: 9.9310344827586pt;'>K P Sasi Cartoons</a>
<a href='http://www.countercurrents.org/tag/narmada-bachao-andolan/' class='tag-link-311 tag-link-position-30' title='40 topics' style='font-size: 12.022988505747pt;'>Narmada Bachao Andolan</a>
<a href='http://www.countercurrents.org/tag/north-korea/' class='tag-link-611 tag-link-position-31' title='32 topics' style='font-size: 10.574712643678pt;'>North Korea</a>
<a href='http://www.countercurrents.org/tag/nuclear-war/' class='tag-link-198 tag-link-position-32' title='26 topics' style='font-size: 9.1264367816092pt;'>Nuclear War</a>
<a href='http://www.countercurrents.org/tag/palestine/' class='tag-link-217 tag-link-position-33' title='74 topics' style='font-size: 16.367816091954pt;'>Palestine</a>
<a href='http://www.countercurrents.org/tag/peak-oil/' class='tag-link-169 tag-link-position-34' title='35 topics' style='font-size: 11.218390804598pt;'>Peak Oil</a>
<a href='http://www.countercurrents.org/tag/poetry/' class='tag-link-228 tag-link-position-35' title='86 topics' style='font-size: 17.333333333333pt;'>Poetry</a>
<a href='http://www.countercurrents.org/tag/resource-crisis/' class='tag-link-170 tag-link-position-36' title='24 topics' style='font-size: 8.6436781609195pt;'>Resource Crisis</a>
<a href='http://www.countercurrents.org/tag/rohingya-muslims/' class='tag-link-872 tag-link-position-37' title='38 topics' style='font-size: 11.701149425287pt;'>Rohingya Muslims</a>
<a href='http://www.countercurrents.org/tag/rss/' class='tag-link-186 tag-link-position-38' title='26 topics' style='font-size: 9.1264367816092pt;'>RSS</a>
<a href='http://www.countercurrents.org/tag/standing-rock-sioux-protest/' class='tag-link-655 tag-link-position-39' title='79 topics' style='font-size: 16.689655172414pt;'>Standing Rock Sioux Protest</a>
<a href='http://www.countercurrents.org/tag/syria/' class='tag-link-244 tag-link-position-40' title='100 topics' style='font-size: 18.298850574713pt;'>Syria</a>
<a href='http://www.countercurrents.org/tag/the-commons/' class='tag-link-344 tag-link-position-41' title='90 topics' style='font-size: 17.655172413793pt;'>The Commons</a>
<a href='http://www.countercurrents.org/tag/turkey/' class='tag-link-309 tag-link-position-42' title='25 topics' style='font-size: 8.8045977011494pt;'>Turkey</a>
<a href='http://www.countercurrents.org/tag/us-elections-2016/' class='tag-link-283 tag-link-position-43' title='89 topics' style='font-size: 17.494252873563pt;'>US Elections 2016</a>
<a href='http://www.countercurrents.org/tag/us-travel-ban/' class='tag-link-1152 tag-link-position-44' title='24 topics' style='font-size: 8.6436781609195pt;'>US Travel Ban</a>
<a href='http://www.countercurrents.org/tag/yemen/' class='tag-link-489 tag-link-position-45' title='32 topics' style='font-size: 10.574712643678pt;'>Yemen</a></div>
<div class="clear"></div></div></div>						</div><!-- /4th column -->


					<div class="clear"></div>
				</div> <!-- /#footer -->

				<div class="clear"></div>


			</div> <!-- /.content-wrap -->

		</div> <!-- /.container -->

		<div id="copyright">
			<div class="inner-wrap">
<!--
				 &copy;  &mdash; <a href="/" class="on"></a>. 				<span> <a href="http://pixnnova.com" target="_blank" title="Pixnnova Infotech">Pixnnova Infotech</a></span>-->

			</div>
		</div>

		<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>

		
		<div id="pum-14374" class="pum pum-overlay pum-theme-14213 pum-theme-default-theme popmake-overlay auto_open click_open" data-popmake="{&quot;id&quot;:14374,&quot;slug&quot;:&quot;annual-subscription&quot;,&quot;theme_id&quot;:14213,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-14374&quot;,&quot;key&quot;:&quot;&quot;,&quot;session&quot;:1,&quot;time&quot;:&quot;1 day&quot;}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;delay&quot;:&quot;500&quot;,&quot;cookie&quot;:{&quot;name&quot;:[&quot;pum-14374&quot;]}}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie&quot;:{&quot;name&quot;:null}}}],&quot;mobile_disabled&quot;:true,&quot;tablet_disabled&quot;:true,&quot;meta&quot;:{&quot;display&quot;:{&quot;size&quot;:&quot;medium&quot;,&quot;responsive_min_width&quot;:&quot;&quot;,&quot;responsive_max_width&quot;:&quot;&quot;,&quot;custom_width&quot;:&quot;640&quot;,&quot;custom_height&quot;:&quot;380&quot;,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;location&quot;:&quot;center top&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;overlay_zindex&quot;:&quot;1999999998&quot;,&quot;zindex&quot;:&quot;1999999999&quot;,&quot;responsive_min_width_unit&quot;:&quot;px&quot;,&quot;responsive_max_width_unit&quot;:&quot;px&quot;,&quot;custom_width_unit&quot;:&quot;px&quot;,&quot;custom_height_unit&quot;:&quot;px&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;1000&quot;},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_14374">

	<div id="popmake-14374" class="pum-container popmake theme-14213 pum-responsive pum-responsive-medium responsive size-medium">

				

				            <div id="pum_popup_title_14374" class="pum-title popmake-title">
				Annual Subscription			</div>
		

		

				<div class="pum-content popmake-content">
			<p><a href="http://www.countercurrents.org/subscription/"><img class="aligncenter size-full wp-image-19176" src="http://www.countercurrents.org/wp-content/uploads/2017/06/subscription-2017New.jpg" alt="subscription-2017New" width="1000" height="1000" /></a></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			CLOSE            </button>
		
	</div>

</div>
<script>(function($){$(document).ready(function(){});})(jQuery);</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.countercurrents.org\/2017\/12\/01\/the-farewell-sermon-of-prophet-muhammad\/":19832,"http:\/\/www.countercurrents.org\/2017\/11\/17\/the-elippathayam-rat-trap-moment-of-indian-cinema\/":19430};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/12/01/the-farewell-sermon-of-prophet-muhammad/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://www.countercurrents.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201748'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/comment-reply.min.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/flexslider.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/jquery.carouFredSel.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/fitvids.min.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/dropdown.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/tabs.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/jquery.placeholder.min.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/functions.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=20170209'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/js/galleria.js'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/js/wzslider.js'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/js/mobile-detect.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"ajaxurl":"http:\/\/www.countercurrents.org\/wp-admin\/admin-ajax.php","restapi":"http:\/\/www.countercurrents.org\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"14213","debug_mode":"","disable_open_tracking":""};
var pum_debug_vars = {"debug_mode_enabled":"Popup Maker Debug Mode Enabled","debug_started_at":"Debug started at:","debug_more_info":"For more information on how to use this information visit http:\/\/docs.wppopupmaker.com\/?utm_medium=js-debug-info&utm_campaign=ContextualHelp&utm_source=browser-console&utm_content=more-info","global_info":"Global Information","localized_vars":"Localized variables","popups_initializing":"Popups Initializing","popups_initialized":"Popups Initialized","single_popup_label":"Popup: #","theme_id":"Theme ID: ","label_method_call":"Method Call:","label_method_args":"Method Arguments:","label_popup_settings":"Settings","label_triggers":"Triggers","label_cookies":"Cookies","label_delay":"Delay:","label_conditions":"Conditions","label_cookie":"Cookie:","label_settings":"Settings:","label_selector":"Selector:","label_mobile_disabled":"Mobile Disabled:","label_tablet_disabled":"Tablet Disabled:","label_display_settings":"Display Settings:","label_close_settings":"Close Settings:","label_event_before_open":"Event: Before Open","label_event_after_open":"Event: After Open","label_event_open_prevented":"Event: Open Prevented","label_event_setup_close":"Event: Setup Close","label_event_close_prevented":"Event: Close Prevented","label_event_before_close":"Event: Before Close","label_event_after_close":"Event: After Close","label_event_before_reposition":"Event: Before Reposition","label_event_after_reposition":"Event: After Reposition","label_event_checking_condition":"Event: Checking Condition","triggers":{"click_open":{"name":"Click Open","modal_title":"Click Trigger Settings","settings_column":"<strong>Extra Selectors<\/strong>: {{data.extra_selectors}}"},"auto_open":{"name":"Auto Open","modal_title":"Auto Open Settings","settings_column":"<strong>Delay<\/strong>: {{data.delay}}"}},"cookies":{"on_popup_open":{"name":"On Popup Open","modal_title":"On Popup Open Settings"},"on_popup_close":{"name":"On Popup Close","modal_title":"On Popup Close Settings"},"manual":{"name":"Manual JavaScript","modal_title":"Click Trigger Settings"}}};
var ajaxurl = "http:\/\/www.countercurrents.org\/wp-admin\/admin-ajax.php";
var popmake_default_theme = "14213";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/js/site.min.js?defer&#038;ver=1.6.6' defer='defer'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/wp-embed.min.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script async="async" type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/frogaloop.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.youtube.com/player_api?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=113156937&postid=19832&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=ddf18eb05dc407aff78fbda50cade16b416aca09#parent=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=113156937&postid=19832&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.9&sig=ddf18eb05dc407aff78fbda50cade16b416aca09#parent=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F12%2F01%2Fthe-farewell-sermon-of-prophet-muhammad%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201748.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'113156937',post:'19832',tz:'0',srv:'www.countercurrents.org'} ]);
	_stq.push([ 'clickTrackerInit', '113156937', '19832' ]);
</script>

	</body>
</html> 