<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    
    <link rel="pingback" href="http://www.countercurrents.org/xmlrpc.php" />

    <title>&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India | Countercurrents</title>

<!-- All in One SEO Pack 2.3.13.2 by Michael Torbert of Semper Fi Web Design[384,515] -->
<meta name="description"  content="Our call for #An Hour For Communal Harmony has got wonderful response from around the country. As our first event, blood and organ donation camps will be held" />

<link rel="canonical" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Feed" href="http://www.countercurrents.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; Comments Feed" href="http://www.countercurrents.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Countercurrents &raquo; &#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India Comments Feed" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.countercurrents.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=fe20cadc087286a088a4a88c070ed9a6"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='popup-maker-site-css'  href='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/css/site.min.css?ver=1.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpz-shortcodes-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/shortcodes.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-font-awesome-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/font-awesome.min.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='alpha-style-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/style.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/css/media-queries.css?ver=2.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A400%2C700%7CSintony%3A400%2C700&#038;ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='socicon-css'  href='http://www.countercurrents.org/wp-content/plugins/social-icons-widget-by-wpzoom/css/socicon.css?ver=20160404' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://www.countercurrents.org/wp-content/plugins/social-icons-widget-by-wpzoom/css/font-awesome.min.css?ver=20160404' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.countercurrents.org/wp-includes/css/dashicons.min.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wzslider-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/css/wzslider.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-theme-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/styles/default.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css'  href='http://www.countercurrents.org/wp-content/themes/alpha/custom.css?ver=fe20cadc087286a088a4a88c070ed9a6' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.countercurrents.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9' type='text/css' media='all' />
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='http://www.countercurrents.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.countercurrents.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.countercurrents.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='24 Pargana Communal Attack: Muslim Fundamentalists Emulating The Hindutva Genre Of Violence' href='http://www.countercurrents.org/2017/07/11/24-pargana-communal-attack-muslim-fundamentalists-emulating-the-hindutva-genre-of-violence/' />

<link rel='shortlink' href='http://www.countercurrents.org/?p=15050' />
<link rel="alternate" type="application/json+oembed" href="http://www.countercurrents.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F07%2F11%2Findia-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.countercurrents.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F07%2F11%2Findia-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="http://www.countercurrents.org/wp-content/plugins/category-specific-rss-feed-menu/wp_cat_rss_style.css" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.countercurrents.org/?wordfence_logHuman=1&hid=ADE5E45482CEBDD350485E4976FDD54C');
</script>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><!-- WPZOOM Theme / Framework -->
<meta name="generator" content="Alpha 2.1.0" />
<meta name="generator" content="WPZOOM Framework 1.6.1" />
<style type="text/css">@import url("http://fonts.googleapis.com/css?family=Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Open+Sans:r,i,b,bi|Merriweather|Merriweather|Open+Sans:r,i,b,bi");
#menutop{background:#040507;}
#menu{background:#FFCC2A;}
#news-ticker{background:#FFFDCA;}
.container{background:#FFFFFF;}
body{color: #000000;font-family: 'Open Sans';font-style: normal;}#logo h1 a{font-family: 'Open Sans';}#slider #slidemain .slide_content h2{font-family: 'Open Sans';font-weight: bold;}.left-col h2, .right-col h4{font-family: 'Open Sans';font-weight: bold;}.archiveposts h2{font-family: 'Merriweather';font-weight: bold;}h1.title{font-family: 'Merriweather';font-weight: bold;}.widget h3.title{font-family: 'Open Sans';font-weight: bold;}</style>
<script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India" />
<meta property="og:url" content="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" />
<meta property="og:description" content="Our call for #An Hour For Communal Harmony  has got wonderful response from around the country. As our first event, blood and organ donation camps will be held in major cities/towns in India in the…" />
<meta property="article:published_time" content="2017-07-11T14:56:07+00:00" />
<meta property="article:modified_time" content="2017-07-11T15:16:27+00:00" />
<meta property="og:site_name" content="Countercurrents" />
<meta property="og:image" content="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?fit=1200%2C1200" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="1200" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:image" content="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?fit=1200%2C1200&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
	<style id="pum-styles" type="text/css" media="all">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</style></head>
<body class="single single-post postid-15050 single-format-standard custom-background">

    <header id="header">

        <div id="menutop">
            <div class="inner-wrap">

                
                    <a class="btn_menu" id="toggle-top" href="#"></a>

                    <div id="topmenu-wrap">

                        <ul id="topmenu" class="dropdown"><li id="menu-item-2096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2096"><a href="http://www.countercurrents.org/subscription/">Subscription</a></li>
<li id="menu-item-2095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2095"><a href="http://www.countercurrents.org/news-letter/">News Letter</a></li>
<li id="menu-item-2003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2003"><a href="http://www.countercurrents.org/fair-use-notice/">Fair Use</a></li>
<li id="menu-item-2004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2004"><a href="http://www.countercurrents.org/disclaimer/">Disclaimer</a></li>
<li id="menu-item-2005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2005"><a href="http://www.countercurrents.org/countercurrents-submission-policy/">Submission</a></li>
<li id="menu-item-2006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006"><a href="http://www.countercurrents.org/contact/">Contact</a></li>
<li id="menu-item-2007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2007"><a href="http://www.countercurrents.org/about/">About</a></li>
</ul>
                    </div>

                
                                    <div id="navsocial">

                        <div id="zoom-social-icons-widget-2" class="widget zoom-social-icons-widget"><h3 class="title">Social Icons</h3>
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://facebook.com/countercurrents" target="_blank">
                                                                                                <span class="socicon socicon-facebook"
                              style="background-color:rgb(59, 89, 152); font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/Countercurrents" target="_blank">
                                                                                                <span class="socicon socicon-twitter"
                              style="background-color:rgb(85, 172, 238); font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://plus.google.com/112168561804759773712" target="_blank">
                                                                                                <span class="socicon socicon-google"
                              style="background-color:rgb(217, 62, 45); font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="http://feeds.feedburner.com/countercurrents/eoKx" target="_blank">
                                                                                                <span class="socicon socicon-rss"
                              style="background-color:#ffcc2a; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.youtube.com/user/CCMEDIACHANNEL" target="_blank">
                                                                                                <span class="socicon socicon-youtube"
                              style="background-color:#bd332f; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
        </ul>

        <div class="clear"></div></div>
                    </div>
                
                <div class="clear"></div>

            </div><!-- /.inner-wrap -->

        </div><!-- /#menutop -->

        <div class="inner-wrap header-wrap">

            <div id="logo">
                
                <a href="http://www.countercurrents.org" title="Educate | Organize | Agitate">
                                            <img src="http://www.countercurrents.org//wp-content/uploads/2016/06/logo-1.png" alt="Countercurrents" />
                                    </a>

                            </div><!-- / #logo -->


            
            <div class="clear"></div>


            <div id="menu">

                <a class="btn_menu" id="toggle-main" href="#"></a>

                <div id="menu-wrap">

                    <ul id="mainmenu" class="dropdown"><li id="menu-item-1887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1887"><a href="http://www.countercurrents.org">Home</a></li>
<li id="menu-item-1848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1848"><a href="http://www.countercurrents.org/category/world/">World</a>
<ul class="sub-menu">
	<li id="menu-item-1822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1822"><a href="http://www.countercurrents.org/category/palestine/">Palestine</a></li>
	<li id="menu-item-2024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2024"><a href="http://www.countercurrents.org/category/imperialism/">Imperialism</a></li>
	<li id="menu-item-2054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2054"><a href="http://www.countercurrents.org/category/south-asia/">South Asia</a></li>
</ul>
</li>
<li id="menu-item-1821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1821"><a href="http://www.countercurrents.org/category/india/">India</a>
<ul class="sub-menu">
	<li id="menu-item-2026" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2026"><a href="http://www.countercurrents.org/category/communal-harmony/">Communal Harmony</a></li>
	<li id="menu-item-2025" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2025"><a href="http://www.countercurrents.org/category/annihilate-caste/">Annihilate Caste</a></li>
	<li id="menu-item-1845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1845"><a href="http://www.countercurrents.org/category/kashmir/">Kashmir</a></li>
</ul>
</li>
<li id="menu-item-2027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2027"><a href="http://www.countercurrents.org/category/climate-change/">Climate Change</a>
<ul class="sub-menu">
	<li id="menu-item-2029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2029"><a href="http://www.countercurrents.org/category/environmental-protection/">Environmental Protection</a></li>
	<li id="menu-item-2030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2030"><a href="http://www.countercurrents.org/category/resource-crisis/">Resource Crisis</a></li>
	<li id="menu-item-2028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2028"><a href="http://www.countercurrents.org/category/counter-solutions/">Counter Solutions</a></li>
	<li id="menu-item-2057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2057"><a href="http://www.countercurrents.org/category/alternative-energy/">Alternative Energy</a></li>
</ul>
</li>
<li id="menu-item-1969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1969"><a href="http://www.countercurrents.org/category/globalisation/">Globalisation</a></li>
<li id="menu-item-2031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2031"><a href="http://www.countercurrents.org/category/patriarchy/">Patriarchy</a></li>
<li id="menu-item-2045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2045"><a href="http://www.countercurrents.org/category/human-rights/">Human Rights</a></li>
<li id="menu-item-2046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2046"><a href="http://www.countercurrents.org/category/life-philosophy/">Life/Philosophy</a>
<ul class="sub-menu">
	<li id="menu-item-2055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2055"><a href="http://www.countercurrents.org/category/arts-literature/">Arts/Literature</a></li>
	<li id="menu-item-2056" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2056"><a href="http://www.countercurrents.org/category/book-review/">Book Review</a></li>
</ul>
</li>
</ul>
                </div>

                
                <div class="clear"></div>

            </div><!-- /#menu -->

        </div><!-- /.inner-wrap -->

    </header>

    	<div class="inner-wrap">
		<div id="news-ticker">

			
			<div class="first">
				<dl id="ticker">
 
				
		 			<p>There are no breaking news at the moment</p>

 				  
				</dl>
			</div>
		 			</div>	
	</div>
    <div class="container">
        <div class="content-wrap">
<div class="single-area">

	 
		<div class="post-meta">
			 
		 	<h1 class="title">
				<a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" title="Permalink to &#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India" rel="bookmark">&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India</a>
			</h1>

			in <a href="http://www.countercurrents.org/category/communal-harmony/" rel="category tag">Communal Harmony</a><span class="separator"> / </span><a href="http://www.countercurrents.org/category/editors-picks/" rel="category tag">Editor's Picks</a> <span class="separator">&mdash;</span>  			by <a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a> <span class="separator">&mdash;</span>			July 11, 2017 					
		</div><!-- /.post-meta -->

	  		<div id="post-15050" class="clearfix post-wrap post-15050 post type-post status-publish format-standard has-post-thumbnail hentry category-communal-harmony category-editors-picks tag-anhourforcommunalharmony tag-india-united-by-blood">
 	 	  
			<div class="entry">
				<p style="text-align: center;"><img class="aligncenter size-full wp-image-15051" src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=690%2C690" alt="blood-poster" srcset="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?w=1389 1389w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=150%2C150 150w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=300%2C300 300w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=768%2C767 768w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=1024%2C1024 1024w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=55%2C55 55w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=75%2C75 75w" sizes="(max-width: 690px) 100vw, 690px" data-recalc-dims="1" /></p>
<p>Our call for <a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/">#An Hour For Communal Harmony</a>  has got wonderful response from around the country. As our first event, blood and organ donation camps will be held in major cities/towns in India in the first week of August. New Delhi, Kolkotta, Mumbai, Chennai, Pune, Trivandurm, Kochi, Calicut have come on board. The slogan of the campaign is &#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221;</p>
<p>I request you to hold a blood and organ donation camp camp in your city/town and join the #AnHourForCommunalHarmony campaign. We&#8217;ve created a campaign poster. I can share the PSD file if you want to follow the same template for poster. Kindly keep the #AnHourForCommunalHarmony hashtag in every poster.</p>
<p>I have created Facebook and Twitter pages for the campaign. Kinldy like and follow these pages</p>
<p><a href="https://www.facebook.com/Anhourforcommunalharmony">https://www.facebook.com/Anhourforcommunalharmony</a>/</p>
<p><a href="https://twitter.com/AnHour4Harmony">https://twitter.com/AnHour4Harmony</a></p>
<p>Hope we can spread it around the world.</p>
<p><strong>Binu Mathew</strong> is the Editor of <a href="http://www.countercurrents.org">www.countercurrents.org</a>. He can be reached at <strong>editor@countercurrents.org</strong></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-15050" class="share-facebook sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-15050" class="share-twitter sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=%22India%20United%20By%20Blood%21%20Share%20It%2C%20Don%27t%20Spill%20It%22%20Campaign%20Springs%20Up%20Across%20India http%3A%2F%2Fwww.countercurrents.org%2F2017%2F07%2F11%2Findia-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-15050" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-15050" class="share-linkedin sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-15050" class="share-pinterest sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-15050" class="share-skype sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>				<div class="clear"></div>
				
								<div class="clear"></div>
			
			</div><!-- / .entry -->
			<div class="clear"></div>
            <div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> 	<div class="clear"></div> 	
			<div class="tag_list">Tags: <a href="http://www.countercurrents.org/tag/anhourforcommunalharmony/" rel="tag">AnHourForCommunalHarmony</a>, <a href="http://www.countercurrents.org/tag/india-united-by-blood/" rel="tag">India United By Blood</a></div>
 	 	</div><!-- #post-15050 -->
					<div class="share_box">
           
           <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.6";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

          <div class="fb-share-button" data-href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" data-layout="button" data-mobile-iframe="true"><a class="fb-xfbml-parse-ignore" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdevelopers.facebook.com%2Fdocs%2Fplugins%2F&amp;src=sdkpreparse">Share</a></div>
           
           
           
            
					<div class="share_btn"><a href="http://twitter.com/share" data-url="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
				<div class="share_btn"><iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.countercurrents.org%2F2017%2F07%2F11%2Findia-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india%2F&amp;layout=button_count&amp;show_faces=false&amp;width=1000&amp;action=like&amp;font=arial&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:80px; height:21px;" allowTransparency="true"></iframe></div>
				<div class="share_btn"><g:plusone size="medium"></g:plusone></div>
				<div class="clear"></div>
			</div> 
		
		
		<div class="clear"></div>

	 	 
					<div class="post-wrap">
<div id="disqus_thread">
    </div>

</div>
				
	  
</div><!-- /.single-area -->
	
	
<div id="sidebar">

		
	
	<div id="text-6" class="widget widget_text"><h3 class="title">Site Search</h3><div class="widget-content">			<div class="textwidget"><div id="search"> 
	<form method="get" id="searchform" action="http://www.google.com/search">
		<input type="text" name="q" id="q" size="30"  value="" placeholder="Site search...">
 <input type="hidden" name="domains" value="http://www.countercurrents.org">
<input type=hidden name=sitesearch value="http://www.countercurrents.org" >		
<input type="submit" name="btnG" id="searchsubmit" class="submit"  VALUE="Search">
		
	</form>
</div></div>
		<div class="clear"></div></div></div><div id="widget_sp_image-3" class="widget widget_sp_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="http://www.countercurrents.org/subscription" id="subscription" target="_self" class="widget_sp_image-image-link" title="Annual Subscription"><img width="300" height="98" alt="Annual Subscription" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?w=327 327w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?resize=300%2C98 300w, https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?resize=168%2C55 168w" sizes="(max-width: 300px) 100vw, 300px" src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/annual-Sub-btn.jpg?fit=300%2C98" /></a><div class="clear"></div></div></div><div id="text-8" class="widget widget_text"><h3 class="title">Join Our News Letter</h3><div class="widget-content">			<div class="textwidget"><form method="post" action="http://scripts.dreamhost.com/add_list.cgi">
        
          <input type="hidden" name="list" value="editor" />
          <input type="hidden" name="domain" value="http://www.countercurrents.org" />
          <input type="hidden" name="url" value="SubscribedURL" />
          <input type="hidden" name="unsuburl" value="UnsubscribedURL" />
          <input type="hidden" name="alreadyonurl" value="AlreadyOnURL" />
          <input type="hidden" name="notonurl" value="NotOnURL" />
          <input type="hidden" name="invalidurl" value="InvalidURL" />
          <input type="hidden" name="emailconfirmurl" value="EmailConfirmURL" />
          <input type="hidden" name="emailit" value="1" />
          
       <p> Name:     <input name="name" />   </p>
        
        <p>E-mail: <input name="email" /></p>
        <p>        
          <input type="submit" name="submit" value="Subscribe" />
          <input type="submit" name="unsub" value="Unsubscribe" />
        </p>
      </form></div>
		<div class="clear"></div></div></div>
			<div id="wpzoom-tabber-2" class="widget tabbertabs"><div class="tabber"><div id="wpzoom-feature-posts-2" class="tabbertab feature-posts"><h2 class="widgettitle">Latest</h2>
<ul class="feature-posts-list"><li><a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/blood-poster-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/">&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/24-pargana-communal-attack-muslim-fundamentalists-emulating-the-hindutva-genre-of-violence/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/baduria-clash-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/24-pargana-communal-attack-muslim-fundamentalists-emulating-the-hindutva-genre-of-violence/">24 Pargana Communal Attack: Muslim Fundamentalists Emulating The Hindutva Genre Of Violence</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/shamsul-islam/" title="Posts by Shamsul Islam" rel="author">Shamsul Islam</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/lost-at-sea-left-liberals-have-no-party/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/Left-Libeberal-Have-No-Party-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/lost-at-sea-left-liberals-have-no-party/">Lost at Sea: Left Liberals Have No Party</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/bruce-lerro/" title="Posts by Bruce Lerro" rel="author">Bruce Lerro</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/creating-a-barren-world/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/moutain-top-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/creating-a-barren-world/">&#8220;Creating A Barren World&#8221;</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/sally-dugman/" title="Posts by Sally Dugman" rel="author">Sally Dugman</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/palante-the-young-lords-in-bridgeport/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/young-lords-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/palante-the-young-lords-in-bridgeport/">Pa’lante: The Young Lords In Bridgeport</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/andy-piascik/" title="Posts by Andy Piascik" rel="author">Andy Piascik</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/men-deny-women-equality-not-the-quran/"><img src="http://www.countercurrents.org/wp-content/uploads/2016/08/tripple-talaq-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/men-deny-women-equality-not-the-quran/">Men Deny Women Equality, Not The Quran </a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/moin-qazi/" title="Posts by Moin Qazi" rel="author">Moin Qazi</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/cultural-shadows-of-the-political-army/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/shadow-armies-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/cultural-shadows-of-the-political-army/">Cultural  Shadows Of The Political Army</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/suraj-kumar-thube/" title="Posts by Suraj Kumar Thube" rel="author">Suraj Kumar Thube</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/11/india-now-5/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/adivasi-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/11/india-now-5/">India Now!</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/k-p-sasi/" title="Posts by K P Sasi" rel="author">K P Sasi</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/building-solidarity-beyond-borders/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/SriLanka_Muslims_Reuters-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/building-solidarity-beyond-borders/">Building Solidarity Beyond Borders</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/meera-srinivasan/" title="Posts by Meera Srinivasan" rel="author">Meera Srinivasan</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/from-growth-to-degrowth-a-brief-history/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/14486751845_b315401d78_b_degrowth-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/from-growth-to-degrowth-a-brief-history/">From Growth To Degrowth: A Brief History</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/genevieve-azam/" title="Posts by Geneviève Azam" rel="author">Geneviève Azam</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/india-now-4/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/Development-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/india-now-4/">India Now!</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/k-p-sasi/" title="Posts by K P Sasi" rel="author">K P Sasi</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/benjamin-salmon_orig-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/">“Ain’t No Such Thing as A Just War” – Ben Salmon, WWI resister</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/kathy-kelly/" title="Posts by Kathy Kelly" rel="author">Kathy Kelly</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/review-disruptive-asia-asias-rise-and-australias-future-exceptionalist-australia-resurgent-asia/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/disruptive-asia-75x50.png" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/review-disruptive-asia-asias-rise-and-australias-future-exceptionalist-australia-resurgent-asia/">Review: “Disruptive Asia. Asia’s Rise And Australia’s Future” – Exceptionalist Australia &#038; Resurgent Asia</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-gideon-polya/" title="Posts by Dr Gideon Polya" rel="author">Dr Gideon Polya</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/power-dynamics-changing-in-world-order/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/Solidarity-without-Borders-G-20-Hamburg-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/power-dynamics-changing-in-world-order/">Power Dynamics Changing In World Order</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/kevin-zeese/" title="Posts by Kevin Zeese" rel="author">Kevin Zeese</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/america-an-empire-in-chaos/"><img src="http://www.countercurrents.org/wp-content/uploads/2016/08/us-troops-syria-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/america-an-empire-in-chaos/">America: An Empire In Chaos</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/gulam-a-mitha/" title="Posts by Gulam A Mitha" rel="author">Gulam A Mitha</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/gst-presidential-order-a-sham/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/gst-protest-jammu-and-kashmir-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/gst-presidential-order-a-sham/">GST Presidential Order &#8211; A Sham</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/abdul-majid-zargar/" title="Posts by Abdul Majid Zargar" rel="author">Abdul Majid Zargar</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/why-are-you-silent/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/02/standing_rock_brusky-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/why-are-you-silent/">Why Are You Silent?</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/sheshu-babu/" title="Posts by Sheshu Babu" rel="author">Sheshu Babu</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/10/revisiting-dablas-work-on-domestic-violence-against-women-in-kashmir-valley/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/domestic-violence-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/10/revisiting-dablas-work-on-domestic-violence-against-women-in-kashmir-valley/">Revisiting Dabla’s Work On Domestic Violence Against Women in Kashmir Valley</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/dr-fayaz-ahmad-bhat/" title="Posts by Dr Fayaz Ahmad Bhat" rel="author">Dr Fayaz Ahmad Bhat</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/India-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/">As India Descends Into Darkness Let’s Spend #AnHourForCommunalHarmony</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a></span>
                <div class="clear"></div></li><li><a href="http://www.countercurrents.org/2017/07/09/tensions-in-hamburg-the-g20-fractures/"><img src="http://www.countercurrents.org/wp-content/uploads/2017/07/g20-hambur-hell-75x50.jpg" height="50" width="75"></a><a href="http://www.countercurrents.org/2017/07/09/tensions-in-hamburg-the-g20-fractures/">Tensions in Hamburg: The G20 Fractures</a> <br />
                <span>-  <a href="http://www.countercurrents.org/author/binoy-kampmark/" title="Posts by Dr Binoy Kampmark" rel="author">Dr Binoy Kampmark</a></span>
                <div class="clear"></div></li></ul><div class="clear"></div></div><div id="wpzoom-popular-news-2" class="tabbertab popular-news"><h2 class="widgettitle">Popular</h2>
<ul class='popular'>
<li><a href='http://www.countercurrents.org/2016/07/26/open-letter-to-major-gaurav-arya-veteran/' rel='bookmark'>Open Letter To Major Gaurav Arya (Veteran)</a> <span class='comments' href='http://www.countercurrents.org/2016/07/26/open-letter-to-major-gaurav-arya-veteran/'>45 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/01/28/trump-orders-military-to-prepare-for-war/' rel='bookmark'>Trump Orders Military To Prepare For War</a> <span class='comments' href='http://www.countercurrents.org/2017/01/28/trump-orders-military-to-prepare-for-war/'>34 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/07/22/poison-in-the-heart-the-nuclear-wasting-of-south-australia/' rel='bookmark'>Poison In The Heart: The Nuclear Wasting Of South Australia</a> <span class='comments' href='http://www.countercurrents.org/2016/07/22/poison-in-the-heart-the-nuclear-wasting-of-south-australia/'>23 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/11/02/rakesh-sharma-demolishes-the-script-of-m-p-police-on-bhopal-encounter/' rel='bookmark'>Rakesh Sharma Demolishes The Script of M.P Police on Bhopal Encounter</a> <span class='comments' href='http://www.countercurrents.org/2016/11/02/rakesh-sharma-demolishes-the-script-of-m-p-police-on-bhopal-encounter/'>19 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/08/04/open-letter-by-burhan-wani-to-major-arya/' rel='bookmark'>Open Letter By Burhan Wani To Major Arya  </a> <span class='comments' href='http://www.countercurrents.org/2016/08/04/open-letter-by-burhan-wani-to-major-arya/'>16 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/04/19/an-open-letter-from-a-kashmiri-student-to-the-people-of-india/' rel='bookmark'>An Open Letter From A Kashmiri Student To The People Of India</a> <span class='comments' href='http://www.countercurrents.org/2017/04/19/an-open-letter-from-a-kashmiri-student-to-the-people-of-india/'>16 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/07/22/koch-brothers-now-supporting-hillary-clinton/' rel='bookmark'> Koch Brothers Now Supporting Hillary Clinton</a> <span class='comments' href='http://www.countercurrents.org/2016/07/22/koch-brothers-now-supporting-hillary-clinton/'>13 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/11/19/demonetisation-and-bhakts/' rel='bookmark'>Demonetisation And Bhakts</a> <span class='comments' href='http://www.countercurrents.org/2016/11/19/demonetisation-and-bhakts/'>13 comments</span></li>
<li><a href='http://www.countercurrents.org/2017/04/25/the-soothing-hand/' rel='bookmark'>The Soothing Hand</a> <span class='comments' href='http://www.countercurrents.org/2017/04/25/the-soothing-hand/'>12 comments</span></li>
<li><a href='http://www.countercurrents.org/2016/09/14/prakash-karat-unable-to-locate-fascism-in-hindutva/' rel='bookmark'>Prakash Karat Unable To Locate Fascism In Hindutva</a> <span class='comments' href='http://www.countercurrents.org/2016/09/14/prakash-karat-unable-to-locate-fascism-in-hindutva/'>11 comments</span></li>
</ul>
</div><div id="wpzoom-recent-comments-2" class="tabbertab recent-comments"><h2 class="widgettitle">Comments</h2>
<ul class="recent-comments-list">
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/america-an-empire-in-chaos/#comment-5907"><img alt='' src='http://1.gravatar.com/avatar/d913f801ed1f86a6c2566773b1b76bc9?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/d913f801ed1f86a6c2566773b1b76bc9?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/america-an-empire-in-chaos/#comment-5907">Obaid Hanafi:</a> Very precise analysis !&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/building-solidarity-beyond-borders/#comment-5906"><img alt='' src='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/building-solidarity-beyond-borders/#comment-5906">K SHESHU BABU:</a> It is sad that a progressive religion like Buddhism has been&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/from-growth-to-degrowth-a-brief-history/#comment-5905"><img alt='' src='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/from-growth-to-degrowth-a-brief-history/#comment-5905">K SHESHU BABU:</a> Informative article on the historic implications of the conc&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/india-now-4/#comment-5904"><img alt='' src='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/india-now-4/#comment-5904">K SHESHU BABU:</a> Development  at the. 'COST' of the people .&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/#comment-5903"><img alt='' src='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/d5a269b9696584e62d4f70474dd8a097?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/#comment-5903">K SHESHU BABU:</a> Wars have devastated nations. The inscription reflects avers&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5902"><img alt='' src='http://0.gravatar.com/avatar/6a98e105f8df98807744dffaba80048a?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/6a98e105f8df98807744dffaba80048a?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5902">Vacy:</a> Brilliant! Small is beautiful, small is powerful, as Binu po&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5900"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5900">rosemerry:</a> Binu is right, and everyone who cares can spent the time he &hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/#comment-5899"><img alt='' src='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=60&#038;r=g' srcset='http://1.gravatar.com/avatar/aa643584c48021ea935d149c52771ee5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/aint-no-such-thing-as-a-just-war-ben-salmon-wwi-resister/#comment-5899">rosemerry:</a> Dear Kathy is also an inspiration to us all. She never gives&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5898"><img alt='' src='http://0.gravatar.com/avatar/fe59d3328d565ba41520aee617c1c133?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/fe59d3328d565ba41520aee617c1c133?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comment-5898">fazal:</a> Just the appropriate thoughts for the present times &amp; ex&hellip;<div class="clear"></div>
		</li>

			
		<li>
			<a href="http://www.countercurrents.org/2017/07/10/why-are-you-silent/#comment-5897"><img alt='' src='http://0.gravatar.com/avatar/f3b7c03a5da013e70a3b0538b3920ef5?s=60&#038;r=g' srcset='http://0.gravatar.com/avatar/f3b7c03a5da013e70a3b0538b3920ef5?s=120&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></a>			<a href="http://www.countercurrents.org/2017/07/10/why-are-you-silent/#comment-5897">Sally Dugman:</a> This is a very powerful poem, Sheshu. It suggestively speaks&hellip;<div class="clear"></div>
		</li>

			</ul></div><div id="tag_cloud-3" class="tabbertab widget_tag_cloud"><h2 class="widgettitle">Tags</h2>
<div class="tagcloud"><a href='http://www.countercurrents.org/tag/ahwazi-arab/' class='tag-link-232 tag-link-position-1' title='19 topics' style='font-size: 8pt;'>Ahwazi Arab</a>
<a href='http://www.countercurrents.org/tag/american-imperialism/' class='tag-link-156 tag-link-position-2' title='81 topics' style='font-size: 17.704545454545pt;'>American Imperialism</a>
<a href='http://www.countercurrents.org/tag/annihilate-caste/' class='tag-link-151 tag-link-position-3' title='33 topics' style='font-size: 11.659090909091pt;'>Annihilate Caste</a>
<a href='http://www.countercurrents.org/tag/bangladesh/' class='tag-link-163 tag-link-position-4' title='19 topics' style='font-size: 8pt;'>Bangladesh</a>
<a href='http://www.countercurrents.org/tag/beef-ban/' class='tag-link-426 tag-link-position-5' title='40 topics' style='font-size: 12.931818181818pt;'>Beef Ban</a>
<a href='http://www.countercurrents.org/tag/beef-ban-lynching/' class='tag-link-573 tag-link-position-6' title='21 topics' style='font-size: 8.6363636363636pt;'>Beef Ban Lynching</a>
<a href='http://www.countercurrents.org/tag/black-lives-matter/' class='tag-link-371 tag-link-position-7' title='20 topics' style='font-size: 8.3181818181818pt;'>Black Lives Matter</a>
<a href='http://www.countercurrents.org/tag/brexit/' class='tag-link-189 tag-link-position-8' title='39 topics' style='font-size: 12.772727272727pt;'>Brexit</a>
<a href='http://www.countercurrents.org/tag/burhan-wani/' class='tag-link-379 tag-link-position-9' title='23 topics' style='font-size: 9.2727272727273pt;'>Burhan Wani</a>
<a href='http://www.countercurrents.org/tag/chhattisgarh/' class='tag-link-145 tag-link-position-10' title='19 topics' style='font-size: 8pt;'>Chhattisgarh</a>
<a href='http://www.countercurrents.org/tag/climate-change/' class='tag-link-174 tag-link-position-11' title='107 topics' style='font-size: 19.613636363636pt;'>Climate Change</a>
<a href='http://www.countercurrents.org/tag/counter-solutions/' class='tag-link-185 tag-link-position-12' title='27 topics' style='font-size: 10.386363636364pt;'>Counter Solutions</a>
<a href='http://www.countercurrents.org/tag/dakota-access-pipeline/' class='tag-link-656 tag-link-position-13' title='80 topics' style='font-size: 17.704545454545pt;'>Dakota Access Pipeline</a>
<a href='http://www.countercurrents.org/tag/demonetisation/' class='tag-link-925 tag-link-position-14' title='106 topics' style='font-size: 19.613636363636pt;'>Demonetisation</a>
<a href='http://www.countercurrents.org/tag/donald-trump/' class='tag-link-353 tag-link-position-15' title='152 topics' style='font-size: 22pt;'>Donald Trump</a>
<a href='http://www.countercurrents.org/tag/education/' class='tag-link-331 tag-link-position-16' title='27 topics' style='font-size: 10.386363636364pt;'>Education</a>
<a href='http://www.countercurrents.org/tag/environment/' class='tag-link-175 tag-link-position-17' title='19 topics' style='font-size: 8pt;'>Environment</a>
<a href='http://www.countercurrents.org/tag/global-warming/' class='tag-link-193 tag-link-position-18' title='66 topics' style='font-size: 16.431818181818pt;'>Global Warming</a>
<a href='http://www.countercurrents.org/tag/gmo/' class='tag-link-209 tag-link-position-19' title='26 topics' style='font-size: 10.068181818182pt;'>GMO</a>
<a href='http://www.countercurrents.org/tag/health/' class='tag-link-301 tag-link-position-20' title='24 topics' style='font-size: 9.5909090909091pt;'>Health</a>
<a href='http://www.countercurrents.org/tag/hillary-clinton/' class='tag-link-308 tag-link-position-21' title='55 topics' style='font-size: 15.159090909091pt;'>Hillary Clinton</a>
<a href='http://www.countercurrents.org/tag/hindutva/' class='tag-link-335 tag-link-position-22' title='22 topics' style='font-size: 8.9545454545455pt;'>Hindutva</a>
<a href='http://www.countercurrents.org/tag/human-rights/' class='tag-link-152 tag-link-position-23' title='50 topics' style='font-size: 14.522727272727pt;'>Human Rights</a>
<a href='http://www.countercurrents.org/tag/india-pakistan-peace-initiative/' class='tag-link-724 tag-link-position-24' title='23 topics' style='font-size: 9.2727272727273pt;'>India-Pakistan Peace Initiative</a>
<a href='http://www.countercurrents.org/tag/iraq/' class='tag-link-357 tag-link-position-25' title='22 topics' style='font-size: 8.9545454545455pt;'>Iraq</a>
<a href='http://www.countercurrents.org/tag/israel/' class='tag-link-218 tag-link-position-26' title='50 topics' style='font-size: 14.522727272727pt;'>Israel</a>
<a href='http://www.countercurrents.org/tag/kashmir/' class='tag-link-164 tag-link-position-27' title='124 topics' style='font-size: 20.727272727273pt;'>Kashmir</a>
<a href='http://www.countercurrents.org/tag/narmada-bachao-andolan/' class='tag-link-311 tag-link-position-28' title='20 topics' style='font-size: 8.3181818181818pt;'>Narmada Bachao Andolan</a>
<a href='http://www.countercurrents.org/tag/nuclear-war/' class='tag-link-198 tag-link-position-29' title='22 topics' style='font-size: 8.9545454545455pt;'>Nuclear War</a>
<a href='http://www.countercurrents.org/tag/palestine/' class='tag-link-217 tag-link-position-30' title='71 topics' style='font-size: 16.909090909091pt;'>Palestine</a>
<a href='http://www.countercurrents.org/tag/patriarchy/' class='tag-link-161 tag-link-position-31' title='21 topics' style='font-size: 8.6363636363636pt;'>Patriarchy</a>
<a href='http://www.countercurrents.org/tag/peak-oil/' class='tag-link-169 tag-link-position-32' title='30 topics' style='font-size: 11.022727272727pt;'>Peak Oil</a>
<a href='http://www.countercurrents.org/tag/poetry/' class='tag-link-228 tag-link-position-33' title='50 topics' style='font-size: 14.522727272727pt;'>Poetry</a>
<a href='http://www.countercurrents.org/tag/refugee-crisis/' class='tag-link-274 tag-link-position-34' title='20 topics' style='font-size: 8.3181818181818pt;'>Refugee Crisis</a>
<a href='http://www.countercurrents.org/tag/resource-crisis/' class='tag-link-170 tag-link-position-35' title='24 topics' style='font-size: 9.5909090909091pt;'>Resource Crisis</a>
<a href='http://www.countercurrents.org/tag/rss/' class='tag-link-186 tag-link-position-36' title='24 topics' style='font-size: 9.5909090909091pt;'>RSS</a>
<a href='http://www.countercurrents.org/tag/russia/' class='tag-link-157 tag-link-position-37' title='19 topics' style='font-size: 8pt;'>Russia</a>
<a href='http://www.countercurrents.org/tag/standing-rock-sioux-protest/' class='tag-link-655 tag-link-position-38' title='79 topics' style='font-size: 17.545454545455pt;'>Standing Rock Sioux Protest</a>
<a href='http://www.countercurrents.org/tag/syria/' class='tag-link-244 tag-link-position-39' title='90 topics' style='font-size: 18.5pt;'>Syria</a>
<a href='http://www.countercurrents.org/tag/the-commons/' class='tag-link-344 tag-link-position-40' title='85 topics' style='font-size: 18.022727272727pt;'>The Commons</a>
<a href='http://www.countercurrents.org/tag/turkey/' class='tag-link-309 tag-link-position-41' title='25 topics' style='font-size: 9.75pt;'>Turkey</a>
<a href='http://www.countercurrents.org/tag/us-elections-2016/' class='tag-link-283 tag-link-position-42' title='89 topics' style='font-size: 18.340909090909pt;'>US Elections 2016</a>
<a href='http://www.countercurrents.org/tag/us-travel-ban/' class='tag-link-1152 tag-link-position-43' title='21 topics' style='font-size: 8.6363636363636pt;'>US Travel Ban</a>
<a href='http://www.countercurrents.org/tag/we-need-their-voices-today/' class='tag-link-1320 tag-link-position-44' title='22 topics' style='font-size: 8.9545454545455pt;'>We Need Their Voices Today</a>
<a href='http://www.countercurrents.org/tag/yemen/' class='tag-link-489 tag-link-position-45' title='25 topics' style='font-size: 9.75pt;'>Yemen</a></div>
</div>
			<div class="clear"></div></div></div><div id="wpzoom-videos-4" class="widget widget_wpzoom_videos"><h3 class="title">Videos            <a href="http://www.countercurrents.org/type/video/" class="see-all">See All &raquo;</a>

            </h3><div class="widget-content">

        <div id="recent-videos" class="flexslider">

            
                    <ul class="slides">

                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/82jFyeV5AHM?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2017/01/16/chennai-poromboke-paadal-ft-tm-krishna/" rel="bookmark" title="Permanent Link to Chennai Poromboke Paadal ft. TM Krishna">Chennai Poromboke Paadal ft. TM Krishna</a></h4>

                            </li>
                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/suBzeCjqRb4?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2017/01/14/notebandi-takes-the-sauce-out-of-nashiks-tomatoes/" rel="bookmark" title="Permanent Link to Notebandi Takes The Sauce Out Of Nashik’s Tomatoes">Notebandi Takes The Sauce Out Of Nashik’s Tomatoes</a></h4>

                            </li>
                                                    <li><div class="post-video"><iframe width=" 300 " height=" 170 " src="https://www.youtube.com/embed/c1UiNHjS12Q?wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
                                <h4><a href="http://www.countercurrents.org/2016/12/30/farmers-continue-to-suffer-pains-of-demonetisation/" rel="bookmark" title="Permanent Link to Farmers Continue To Suffer Pains Of Demonetisation">Farmers Continue To Suffer Pains Of Demonetisation</a></h4>

                            </li>
                        
                    </ul>


            

        </div>

<div class="clear"></div></div></div>		<div class="featured-category">
            <h3 class="green"><a href="http://www.countercurrents.org/category/editors-picks/">Editor&#8217;s Picks</a></h3>
            
			
				<div class="left-col">

					<a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" title="&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/blood-poster.jpg?resize=300%2C200" alt="&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India" class="Thumbnail thumbnail featured-cat " width="300" height="200" /></a>					<div class="clear"></div>

					<div class="left-col-content">

						<h2><a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" title="&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India">&#8220;India United By Blood! Share It, Don&#8217;t Spill It&#8221; Campaign Springs Up Across India</a></h2>

						<div class="featured-meta">
							<!--<span></span>-->
                            by							<a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a>							<span class="separator">&mdash;</span>
							<span><a href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/#respond"><span class="dsq-postid" data-dsqidentifier="15050 http://www.countercurrents.org/?p=15050">0 comments</span></a></span>
						</div>

						<p>Our call for #An Hour For Communal Harmony  has got wonderful response from around the country. As our first event, blood and organ donation camps will be held in major cities/towns in India in the first week of August. New Delhi, Kolkotta, Mumbai, Chennai, Pune, Trivandurm, Kochi, Calicut have come on board. The slogan of the campaign is &#8220;India United<a class="more-link" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/">[Read More&#8230;]</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-15050" class="share-facebook sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-15050" class="share-twitter sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=%22India%20United%20By%20Blood%21%20Share%20It%2C%20Don%27t%20Spill%20It%22%20Campaign%20Springs%20Up%20Across%20India http%3A%2F%2Fwww.countercurrents.org%2F2017%2F07%2F11%2Findia-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-15050" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-15050" class="share-linkedin sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-15050" class="share-pinterest sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-15050" class="share-skype sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="http://www.countercurrents.org/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					</div>

				</div>

				<div class="right-col">
					<ul>

											
						<li>
							<a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/" title="As India Descends Into Darkness Let’s Spend #AnHourForCommunalHarmony"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/07/India.jpg?resize=100%2C75" alt="As India Descends Into Darkness Let’s Spend #AnHourForCommunalHarmony" class="Thumbnail thumbnail featured-cat-small " width="100" height="75" /></a>
							<div class="right-col-content">

								<h4><a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/" title="As India Descends Into Darkness Let’s Spend #AnHourForCommunalHarmony">As India Descends Into Darkness Let’s Spend #AnHourForCommunalHarmony</a></h4>

								<div class="featured-meta">
									<!--<span>July 9, 2017</span>-->
                                    by							<a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a>									<span class="separator">&mdash;</span>
									<span><a href="http://www.countercurrents.org/2017/07/09/as-india-descends-into-darkness-lets-spend-anhourforcommunalharmony/#comments"><span class="dsq-postid" data-dsqidentifier="14982 http://www.countercurrents.org/?p=14982">6 comments</span></a></span>
								</div>

							</div>

							<div style="clear:both;"></div>

						</li>

												
						<li>
							<a href="http://www.countercurrents.org/2017/06/27/a-thousand-flowers-should-bloom-for-junaid/" title=" A Thousand Flowers Should Bloom For Junaid"><img src="https://i2.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/Injured-Junaid-1.jpg?resize=100%2C75" alt=" A Thousand Flowers Should Bloom For Junaid" class="Thumbnail thumbnail featured-cat-small " width="100" height="75" /></a>
							<div class="right-col-content">

								<h4><a href="http://www.countercurrents.org/2017/06/27/a-thousand-flowers-should-bloom-for-junaid/" title=" A Thousand Flowers Should Bloom For Junaid"> A Thousand Flowers Should Bloom For Junaid</a></h4>

								<div class="featured-meta">
									<!--<span>June 27, 2017</span>-->
                                    by							<a href="http://www.countercurrents.org/author/binu-mathew/" title="Posts by Binu Mathew" rel="author">Binu Mathew</a>									<span class="separator">&mdash;</span>
									<span><a href="http://www.countercurrents.org/2017/06/27/a-thousand-flowers-should-bloom-for-junaid/#comments"><span class="dsq-postid" data-dsqidentifier="14601 http://www.countercurrents.org/?p=14601">5 comments</span></a></span>
								</div>

							</div>

							<div style="clear:both;"></div>

						</li>

																	</ul>
	              	            </div>
				<div class="clear"></div>
		</div><!-- / .category -->
 <!-- / .featCategory --><div id="archives-2" class="widget widget_archive"><h3 class="title">Archives</h3><div class="widget-content">		<ul>
			<li><a href='http://www.countercurrents.org/2017/07/'>July 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/06/'>June 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/05/'>May 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/04/'>April 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/03/'>March 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/02/'>February 2017</a></li>
	<li><a href='http://www.countercurrents.org/2017/01/'>January 2017</a></li>
	<li><a href='http://www.countercurrents.org/2016/12/'>December 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/11/'>November 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/10/'>October 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/09/'>September 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/08/'>August 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/07/'>July 2016</a></li>
	<li><a href='http://www.countercurrents.org/2016/06/'>June 2016</a></li>
		</ul>
		<div class="clear"></div></div></div><div id="widget_sp_image-4" class="widget widget_sp_image"><h3 class="title"><div class="empty"></div></h3><div class="widget-content"><a href="http://www.countercurrents.org/archive.htm" target="_self" class="widget_sp_image-image-link" title="Older Archive"><img width="300" height="98" alt="Older Archive" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?w=327 327w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?resize=300%2C98 300w, https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?resize=168%2C55 168w" sizes="(max-width: 300px) 100vw, 300px" src="https://i1.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/older-archive-btn.jpg?fit=300%2C98" /></a><div class="clear"></div></div></div><div id="text-3" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=258076111050631";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div class="fb-page" data-href="https://www.facebook.com/countercurrents/" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/countercurrents/"><a href="https://www.facebook.com/countercurrents/">Countercurrents</a></blockquote></div></div></div>
		<div class="clear"></div></div></div><div id="text-4" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget">
<a href="https://twitter.com/Countercurrents" class="twitter-follow-button" data-show-count="false" data-size="large" data-dnt="true">Follow @Countercurrents</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>


</div>
		<div class="clear"></div></div></div><div id="text-11" class="widget widget_text"><h3 class="title"><div class="empty"></div></h3><div class="widget-content">			<div class="textwidget"><!-- Place this tag in your head or just before your close body tag. -->
<script src="https://apis.google.com/js/platform.js" async defer></script>

<!-- Place this tag where you want the widget to render. -->
<div class="g-page" data-href="https://plus.google.com/112168561804759773712" data-rel="publisher"></div></div>
		<div class="clear"></div></div></div><div id="widget_sp_image-5" class="widget widget_sp_image"><h3 class="title">Countercurrents Anthology-Vol 1</h3><div class="widget-content"><a href="http://peoplesbookshop.com/product/countercurrents-connecting-dots-anthology/" target="_self" class="widget_sp_image-image-link" title="Countercurrents Anthology-Vol 1"><img width="300" height="300" alt="Countercurrents Anthology-Vol 1" class="attachment-full" style="max-width: 100%;" srcset="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?w=300 300w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=150%2C150 150w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=55%2C55 55w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?resize=75%2C75 75w" sizes="(max-width: 300px) 100vw, 300px" src="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2017/06/countercurrents-booknew.jpg?fit=300%2C300" /></a><div class="clear"></div></div></div><div id="widget_sp_image-2" class="widget widget_sp_image"><h3 class="title">Countercurrents Youtube Channel</h3><div class="widget-content"><a href="http://www.youtube.com/ccmediachannel" target="_blank" class="widget_sp_image-image-link" title="Countercurrents Youtube Channel"><img width="327" height="107" alt="Countercurrents Youtube Channel" class="attachment-full aligncenter" style="max-width: 100%;" srcset="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?w=327 327w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?resize=300%2C98 300w, https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?resize=168%2C55 168w" sizes="(max-width: 327px) 100vw, 327px" src="https://i0.wp.com/www.countercurrents.org/wp-content/uploads/2016/06/Counter-Currents-youtube.jpg?fit=327%2C107" /></a><div class="clear"></div></div></div> 
		
  
		 
</div> <!-- /#sidebar --> 
				<div class="clear"></div>

				<div id="footer">

						<div class="column">
							<div id="text-2" class="widget widget_text"><h3 class="title">Annual Subscription</h3><div class="widget-content">			<div class="textwidget">If you like what you are reading please join our annual subscription programme. Countercurrents.org is a 100% reader supported website.  We believe independent journalism will function properly only if it is economically independent.  We do not accept advertising by our policy. We would rather die than accept advertisements from corporate giants. A small annual subscription sustains us. Get an annual subscription 
<a href="http://www.countercurrents.org/cc/subscription">HERE</a>
</div>
		<div class="clear"></div></div></div>						</div><!-- /1st column -->

						<div class="column">
							<div id="text-13" class="widget widget_text"><h3 class="title">Join Our News Letter</h3><div class="widget-content">			<div class="textwidget">Keep Uptodate With The World!!! Join Our News Letter Today !! We tell you what the mainstream media fails to tell you, or hides from you. These are the things that really matter. The things which may determine the fate of planet earth! The future of our children! In a word, the survival of the species! To receive our daily news digest please click <a href="http://www.countercurrents.org/cc/news-letter/">HERE</a></div>
		<div class="clear"></div></div></div>						</div><!-- /2nd column -->

						<div class="column">
							<div id="text-12" class="widget widget_text"><h3 class="title">Submission Guidelines</h3><div class="widget-content">			<div class="textwidget">Countercurrents.org welcomes articles from writers, activists, journalists and also from our readers who have no prior experience in writing, on topics that we deal with regularly or on topics that you think need a wider circulation. Kindly use the word "SUBMISSION" in the subject line You can submit your articles to editor@countercurrents.org. More Submission guidelines are <a href="http://www.countercurrents.org/cc/countercurrents-submission-policy/"> HERE</a> </div>
		<div class="clear"></div></div></div>						</div><!-- /3rd column -->

						<div class="column last">
							<div id="tag_cloud-4" class="widget widget_tag_cloud"><h3 class="title">Popular Tags</h3><div class="widget-content"><div class="tagcloud"><a href='http://www.countercurrents.org/tag/ahwazi-arab/' class='tag-link-232 tag-link-position-1' title='19 topics' style='font-size: 8pt;'>Ahwazi Arab</a>
<a href='http://www.countercurrents.org/tag/american-imperialism/' class='tag-link-156 tag-link-position-2' title='81 topics' style='font-size: 17.704545454545pt;'>American Imperialism</a>
<a href='http://www.countercurrents.org/tag/annihilate-caste/' class='tag-link-151 tag-link-position-3' title='33 topics' style='font-size: 11.659090909091pt;'>Annihilate Caste</a>
<a href='http://www.countercurrents.org/tag/bangladesh/' class='tag-link-163 tag-link-position-4' title='19 topics' style='font-size: 8pt;'>Bangladesh</a>
<a href='http://www.countercurrents.org/tag/beef-ban/' class='tag-link-426 tag-link-position-5' title='40 topics' style='font-size: 12.931818181818pt;'>Beef Ban</a>
<a href='http://www.countercurrents.org/tag/beef-ban-lynching/' class='tag-link-573 tag-link-position-6' title='21 topics' style='font-size: 8.6363636363636pt;'>Beef Ban Lynching</a>
<a href='http://www.countercurrents.org/tag/black-lives-matter/' class='tag-link-371 tag-link-position-7' title='20 topics' style='font-size: 8.3181818181818pt;'>Black Lives Matter</a>
<a href='http://www.countercurrents.org/tag/brexit/' class='tag-link-189 tag-link-position-8' title='39 topics' style='font-size: 12.772727272727pt;'>Brexit</a>
<a href='http://www.countercurrents.org/tag/burhan-wani/' class='tag-link-379 tag-link-position-9' title='23 topics' style='font-size: 9.2727272727273pt;'>Burhan Wani</a>
<a href='http://www.countercurrents.org/tag/chhattisgarh/' class='tag-link-145 tag-link-position-10' title='19 topics' style='font-size: 8pt;'>Chhattisgarh</a>
<a href='http://www.countercurrents.org/tag/climate-change/' class='tag-link-174 tag-link-position-11' title='107 topics' style='font-size: 19.613636363636pt;'>Climate Change</a>
<a href='http://www.countercurrents.org/tag/counter-solutions/' class='tag-link-185 tag-link-position-12' title='27 topics' style='font-size: 10.386363636364pt;'>Counter Solutions</a>
<a href='http://www.countercurrents.org/tag/dakota-access-pipeline/' class='tag-link-656 tag-link-position-13' title='80 topics' style='font-size: 17.704545454545pt;'>Dakota Access Pipeline</a>
<a href='http://www.countercurrents.org/tag/demonetisation/' class='tag-link-925 tag-link-position-14' title='106 topics' style='font-size: 19.613636363636pt;'>Demonetisation</a>
<a href='http://www.countercurrents.org/tag/donald-trump/' class='tag-link-353 tag-link-position-15' title='152 topics' style='font-size: 22pt;'>Donald Trump</a>
<a href='http://www.countercurrents.org/tag/education/' class='tag-link-331 tag-link-position-16' title='27 topics' style='font-size: 10.386363636364pt;'>Education</a>
<a href='http://www.countercurrents.org/tag/environment/' class='tag-link-175 tag-link-position-17' title='19 topics' style='font-size: 8pt;'>Environment</a>
<a href='http://www.countercurrents.org/tag/global-warming/' class='tag-link-193 tag-link-position-18' title='66 topics' style='font-size: 16.431818181818pt;'>Global Warming</a>
<a href='http://www.countercurrents.org/tag/gmo/' class='tag-link-209 tag-link-position-19' title='26 topics' style='font-size: 10.068181818182pt;'>GMO</a>
<a href='http://www.countercurrents.org/tag/health/' class='tag-link-301 tag-link-position-20' title='24 topics' style='font-size: 9.5909090909091pt;'>Health</a>
<a href='http://www.countercurrents.org/tag/hillary-clinton/' class='tag-link-308 tag-link-position-21' title='55 topics' style='font-size: 15.159090909091pt;'>Hillary Clinton</a>
<a href='http://www.countercurrents.org/tag/hindutva/' class='tag-link-335 tag-link-position-22' title='22 topics' style='font-size: 8.9545454545455pt;'>Hindutva</a>
<a href='http://www.countercurrents.org/tag/human-rights/' class='tag-link-152 tag-link-position-23' title='50 topics' style='font-size: 14.522727272727pt;'>Human Rights</a>
<a href='http://www.countercurrents.org/tag/india-pakistan-peace-initiative/' class='tag-link-724 tag-link-position-24' title='23 topics' style='font-size: 9.2727272727273pt;'>India-Pakistan Peace Initiative</a>
<a href='http://www.countercurrents.org/tag/iraq/' class='tag-link-357 tag-link-position-25' title='22 topics' style='font-size: 8.9545454545455pt;'>Iraq</a>
<a href='http://www.countercurrents.org/tag/israel/' class='tag-link-218 tag-link-position-26' title='50 topics' style='font-size: 14.522727272727pt;'>Israel</a>
<a href='http://www.countercurrents.org/tag/kashmir/' class='tag-link-164 tag-link-position-27' title='124 topics' style='font-size: 20.727272727273pt;'>Kashmir</a>
<a href='http://www.countercurrents.org/tag/narmada-bachao-andolan/' class='tag-link-311 tag-link-position-28' title='20 topics' style='font-size: 8.3181818181818pt;'>Narmada Bachao Andolan</a>
<a href='http://www.countercurrents.org/tag/nuclear-war/' class='tag-link-198 tag-link-position-29' title='22 topics' style='font-size: 8.9545454545455pt;'>Nuclear War</a>
<a href='http://www.countercurrents.org/tag/palestine/' class='tag-link-217 tag-link-position-30' title='71 topics' style='font-size: 16.909090909091pt;'>Palestine</a>
<a href='http://www.countercurrents.org/tag/patriarchy/' class='tag-link-161 tag-link-position-31' title='21 topics' style='font-size: 8.6363636363636pt;'>Patriarchy</a>
<a href='http://www.countercurrents.org/tag/peak-oil/' class='tag-link-169 tag-link-position-32' title='30 topics' style='font-size: 11.022727272727pt;'>Peak Oil</a>
<a href='http://www.countercurrents.org/tag/poetry/' class='tag-link-228 tag-link-position-33' title='50 topics' style='font-size: 14.522727272727pt;'>Poetry</a>
<a href='http://www.countercurrents.org/tag/refugee-crisis/' class='tag-link-274 tag-link-position-34' title='20 topics' style='font-size: 8.3181818181818pt;'>Refugee Crisis</a>
<a href='http://www.countercurrents.org/tag/resource-crisis/' class='tag-link-170 tag-link-position-35' title='24 topics' style='font-size: 9.5909090909091pt;'>Resource Crisis</a>
<a href='http://www.countercurrents.org/tag/rss/' class='tag-link-186 tag-link-position-36' title='24 topics' style='font-size: 9.5909090909091pt;'>RSS</a>
<a href='http://www.countercurrents.org/tag/russia/' class='tag-link-157 tag-link-position-37' title='19 topics' style='font-size: 8pt;'>Russia</a>
<a href='http://www.countercurrents.org/tag/standing-rock-sioux-protest/' class='tag-link-655 tag-link-position-38' title='79 topics' style='font-size: 17.545454545455pt;'>Standing Rock Sioux Protest</a>
<a href='http://www.countercurrents.org/tag/syria/' class='tag-link-244 tag-link-position-39' title='90 topics' style='font-size: 18.5pt;'>Syria</a>
<a href='http://www.countercurrents.org/tag/the-commons/' class='tag-link-344 tag-link-position-40' title='85 topics' style='font-size: 18.022727272727pt;'>The Commons</a>
<a href='http://www.countercurrents.org/tag/turkey/' class='tag-link-309 tag-link-position-41' title='25 topics' style='font-size: 9.75pt;'>Turkey</a>
<a href='http://www.countercurrents.org/tag/us-elections-2016/' class='tag-link-283 tag-link-position-42' title='89 topics' style='font-size: 18.340909090909pt;'>US Elections 2016</a>
<a href='http://www.countercurrents.org/tag/us-travel-ban/' class='tag-link-1152 tag-link-position-43' title='21 topics' style='font-size: 8.6363636363636pt;'>US Travel Ban</a>
<a href='http://www.countercurrents.org/tag/we-need-their-voices-today/' class='tag-link-1320 tag-link-position-44' title='22 topics' style='font-size: 8.9545454545455pt;'>We Need Their Voices Today</a>
<a href='http://www.countercurrents.org/tag/yemen/' class='tag-link-489 tag-link-position-45' title='25 topics' style='font-size: 9.75pt;'>Yemen</a></div>
<div class="clear"></div></div></div>						</div><!-- /4th column -->


					<div class="clear"></div>
				</div> <!-- /#footer -->

				<div class="clear"></div>


			</div> <!-- /.content-wrap -->

		</div> <!-- /.container -->

		<div id="copyright">
			<div class="inner-wrap">
<!--
				 &copy;  &mdash; <a href="/" class="on"></a>. 				<span> <a href="http://pixnnova.com" target="_blank" title="Pixnnova Infotech">Pixnnova Infotech</a></span>-->

			</div>
		</div>

		<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>

		
		<div id="pum-14374" class="pum pum-overlay pum-theme-14213 popmake-overlay auto_open click_open" data-popmake="{&quot;id&quot;:14374,&quot;slug&quot;:&quot;annual-subscription&quot;,&quot;theme_id&quot;:14213,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-14374&quot;,&quot;key&quot;:&quot;&quot;,&quot;session&quot;:1,&quot;time&quot;:&quot;1 day&quot;}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;delay&quot;:&quot;500&quot;,&quot;cookie&quot;:{&quot;name&quot;:[&quot;pum-14374&quot;]}}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie&quot;:{&quot;name&quot;:null}}}],&quot;mobile_disabled&quot;:true,&quot;tablet_disabled&quot;:true,&quot;meta&quot;:{&quot;display&quot;:{&quot;size&quot;:&quot;medium&quot;,&quot;responsive_min_width&quot;:&quot;&quot;,&quot;responsive_max_width&quot;:&quot;&quot;,&quot;custom_width&quot;:&quot;640&quot;,&quot;custom_height&quot;:&quot;380&quot;,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;location&quot;:&quot;center top&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;overlay_zindex&quot;:&quot;1999999998&quot;,&quot;zindex&quot;:&quot;1999999999&quot;,&quot;responsive_min_width_unit&quot;:&quot;px&quot;,&quot;responsive_max_width_unit&quot;:&quot;px&quot;,&quot;custom_width_unit&quot;:&quot;px&quot;,&quot;custom_height_unit&quot;:&quot;px&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;1000&quot;},&quot;click_open&quot;:{&quot;extra_selectors&quot;:&quot;&quot;}}}" role="dialog" aria-hidden="true" aria-labelledby="pum_popup_title_14374">

	<div id="popmake-14374" class="pum-container popmake theme-14213 pum-responsive pum-responsive-medium responsive size-medium">

				

				            <div id="pum_popup_title_14374" class="pum-title popmake-title">
				Annual Subscription			</div>
		

		

				<div class="pum-content popmake-content">
			<p><a href="http://www.countercurrents.org/subscription/"><img class="aligncenter size-full wp-image-14375" src="http://www.countercurrents.org/wp-content/uploads/2017/06/subscription-flame.jpg" alt="subscription-flame" width="750" height="750" /></a></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			CLOSE            </button>
		
	</div>

</div>
<script>(function($){$(document).ready(function(){});})(jQuery);</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.countercurrents.org\/2017\/07\/11\/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india\/":15050};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/07/11/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="http://www.countercurrents.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201728'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/comment-reply.min.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/flexslider.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/jquery.carouFredSel.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/fitvids.min.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/dropdown.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/tabs.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/jquery.placeholder.min.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/functions.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/js/galleria.js'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/functions/wpzoom/assets/js/wzslider.js'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/js/mobile-detect.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"ajaxurl":"http:\/\/www.countercurrents.org\/wp-admin\/admin-ajax.php","restapi":"http:\/\/www.countercurrents.org\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"14213","debug_mode":"","disable_open_tracking":""};
var pum_debug_vars = {"debug_mode_enabled":"Popup Maker Debug Mode Enabled","debug_started_at":"Debug started at:","debug_more_info":"For more information on how to use this information visit http:\/\/docs.wppopupmaker.com\/?utm_medium=js-debug-info&utm_campaign=ContextualHelp&utm_source=browser-console&utm_content=more-info","global_info":"Global Information","localized_vars":"Localized variables","popups_initializing":"Popups Initializing","popups_initialized":"Popups Initialized","single_popup_label":"Popup: #","theme_id":"Theme ID: ","label_method_call":"Method Call:","label_method_args":"Method Arguments:","label_popup_settings":"Settings","label_triggers":"Triggers","label_cookies":"Cookies","label_delay":"Delay:","label_conditions":"Conditions","label_cookie":"Cookie:","label_settings":"Settings:","label_selector":"Selector:","label_mobile_disabled":"Mobile Disabled:","label_tablet_disabled":"Tablet Disabled:","label_display_settings":"Display Settings:","label_close_settings":"Close Settings:","label_event_before_open":"Event: Before Open","label_event_after_open":"Event: After Open","label_event_open_prevented":"Event: Open Prevented","label_event_setup_close":"Event: Setup Close","label_event_close_prevented":"Event: Close Prevented","label_event_before_close":"Event: Before Close","label_event_after_close":"Event: After Close","label_event_before_reposition":"Event: Before Reposition","label_event_after_reposition":"Event: After Reposition","label_event_checking_condition":"Event: Checking Condition","triggers":{"click_open":{"name":"Click Open","modal_title":"Click Trigger Settings","settings_column":"<strong>Extra Selectors<\/strong>: {{data.extra_selectors}}"},"auto_open":{"name":"Auto Open","modal_title":"Auto Open Settings","settings_column":"<strong>Delay<\/strong>: {{data.delay}}"}},"cookies":{"on_popup_open":{"name":"On Popup Open","modal_title":"On Popup Open Settings"},"on_popup_close":{"name":"On Popup Close","modal_title":"On Popup Close Settings"},"manual":{"name":"Manual JavaScript","modal_title":"Click Trigger Settings"}}};
var ajaxurl = "http:\/\/www.countercurrents.org\/wp-admin\/admin-ajax.php";
var popmake_default_theme = "14213";
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/popup-maker/assets/js/site.min.js?defer&#038;ver=1.6.4' defer='defer'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-includes/js/wp-embed.min.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.6.2","language":""},"disqusIdentifier":"15050 http:\/\/www.countercurrents.org\/?p=15050","disqusShortname":"www-countercurrents-org","disqusTitle":"\u201cIndia United By Blood! Share It, Don\u2019t Spill It\u201d Campaign Springs Up Across India","disqusUrl":"http:\/\/www.countercurrents.org\/2017\/07\/11\/india-united-by-blood-share-it-dont-spill-it-campaign-springs-up-across-india\/","options":{"manualSync":false},"postId":"15050"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/themes/alpha/js/frogaloop.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://www.youtube.com/player_api?ver=2.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"www-countercurrents-org"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=fe20cadc087286a088a4a88c070ed9a6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.countercurrents.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201728.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'113156937',post:'15050',tz:'0',srv:'www.countercurrents.org'} ]);
	_stq.push([ 'clickTrackerInit', '113156937', '15050' ]);
</script>

	</body>
</html> 